ipq806x: provide ramoops for R7800/XR500 by default
authorHannu Nyman <hannu.nyman@iki.fi>
Sun, 6 Mar 2022 09:56:15 +0000 (11:56 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 8 Mar 2022 17:33:42 +0000 (18:33 +0100)
Add kmod-ramoops to the default set of device packages in
R7800 and XR500, so that the ramoops kernel crash logs
are provided by default for these routers.

The capability was earlier defined by 97158fe1 and cf346dfa,
but the feature was not yet turned on by default.

The possible kernel crashes are stored into /sys/fs/pstore/*

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
target/linux/ipq806x/image/generic.mk

index 11592ad97e4131e07e48c0e6fe83ccdde0bdfc2e..819c73d338ceb83d866d31b6c585a0a3402a60f2 100644 (file)
@@ -304,7 +304,7 @@ define Device/netgear_r7800
        PAGESIZE := 2048
        BOARD_NAME := r7800
        SUPPORTED_DEVICES += r7800
-       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct kmod-ramoops
 endef
 TARGET_DEVICES += netgear_r7800
 
@@ -318,7 +318,7 @@ define Device/netgear_xr500
        NETGEAR_HW_ID := 29764958+0+256+512+4x4+4x4+cascade
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct kmod-ramoops
 endef
 TARGET_DEVICES += netgear_xr500