ramips: limit dictionary size for lzma compression
authorFelix Fietkau <nbd@nbd.name>
Tue, 19 Jun 2018 08:06:50 +0000 (10:06 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 3 Jul 2018 09:20:37 +0000 (11:20 +0200)
In some cases, recent builds fail to boot from flash with at least some
MT7621 based devices. The error message is:
"LZMA ERROR 1 - must RESET board to recover"
Booting the same kernel via TFTP works for some reason.

Through testing I figured out that limiting the LZMA dictionary size
seems to prevent these errors

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/ramips/image/Makefile

index 8ab8aa3a6c9f187600cb50879ec68e7f0681583a..cd77ffe411913c7aeac651290f8d87ae8e152558 100644 (file)
@@ -31,7 +31,7 @@ loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
 
 KERNEL_LOADADDR := $(loadaddr-y)
 
-KERNEL_DTB = kernel-bin | patch-dtb | lzma
+KERNEL_DTB = kernel-bin | patch-dtb | lzma -d21
 define Device/Default
   PROFILES = Default $$(DTS)
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)