sunxi: fix uboot install location
authorZoltan Herpai <wigyori@uid0.hu>
Sat, 15 Aug 2015 14:34:42 +0000 (14:34 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Sat, 15 Aug 2015 14:34:42 +0000 (14:34 +0000)
Install uboot files to KERNEL_BUILD_DIR instead of BIN_DIR to fix
ImageBuilder. Similar fixes are necessary for many (all?) other uboot
targets.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 46605

package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/Makefile

index 1aeeceb9e07069e26b28720d10c0ddf4543b2e7c..b08f9ed1df0fc85801b5c11ff20024e5a73708ca 100644 (file)
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:= \
 
 PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
 
 
 PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_LICENSE:=GPL-2.0 GPL-2.0+
 PKG_LICENSE_FILES:=Licenses/README
 
 PKG_LICENSE:=GPL-2.0 GPL-2.0+
 PKG_LICENSE_FILES:=Licenses/README
@@ -138,16 +138,16 @@ define Build/Compile
 endef
 
 define Package/uboot/install/default
 endef
 
 define Package/uboot/install/default
-       $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
        $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
        $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.bin
+               $(KERNEL_BUILD_DIR)/uboot-$(BOARD)-$(1)-u-boot.bin
        $(CP) $(PKG_BUILD_DIR)/spl/sunxi-spl.bin \
        $(CP) $(PKG_BUILD_DIR)/spl/sunxi-spl.bin \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-spl.bin
+               $(KERNEL_BUILD_DIR)/uboot-$(BOARD)-$(1)-spl.bin
        $(CP) $(PKG_BUILD_DIR)/u-boot-sunxi-with-spl.bin \
        $(CP) $(PKG_BUILD_DIR)/u-boot-sunxi-with-spl.bin \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot-with-spl.bin
+               $(KERNEL_BUILD_DIR)/uboot-$(BOARD)-$(1)-u-boot-with-spl.bin
        $(CP) uEnv.txt \
        $(CP) uEnv.txt \
-               $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-uEnv.txt
-       mkimage -C none -A arm -T script -d $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-uEnv.txt $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-boot.scr
+               $(KERNEL_BUILD_DIR)/uboot-$(BOARD)-$(1)-uEnv.txt
+       mkimage -C none -A arm -T script -d $(KERNEL_BUILD_DIR)/uboot-$(BOARD)-$(1)-uEnv.txt \
+               $(KERNEL_BUILD_DIR)/uboot-$(BOARD)-$(1)-boot.scr
 endef
 
 define Package/uboot/install/template
 endef
 
 define Package/uboot/install/template
index b96a360b551a86293ecdf7060da903be0b76db2c..19ab935f3b80f942b5b2f9a69f66d85cc8c67497 100644 (file)
@@ -32,7 +32,7 @@ define Image/Build/SDCard
        rm -f $(KDIR)/boot.img
        mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
 
        rm -f $(KDIR)/boot.img
        mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
 
-       mcopy -i $(KDIR)/boot.img $(BIN_DIR)/uboot-sunxi-$(PROFILE)/$(IMG_PREFIX)-$(PROFILE)-boot.scr ::boot.scr
+       mcopy -i $(KDIR)/boot.img $(KDIR)/uboot-sunxi-$(PROFILE)-boot.scr ::boot.scr
        mcopy -i $(KDIR)/boot.img $(DTS_DIR)/$(2).dtb ::dtb
        mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
 
        mcopy -i $(KDIR)/boot.img $(DTS_DIR)/$(2).dtb ::dtb
        mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
 
@@ -42,7 +42,7 @@ define Image/Build/SDCard
                $(KDIR)/root.$(1) \
                $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
                $(KDIR)/root.$(1) \
                $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
-               $(BIN_DIR)/uboot-sunxi-$(PROFILE)/$(IMG_PREFIX)-$(PROFILE)-u-boot-with-spl.bin
+               $(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
 endef
 
 define Image/Build/Profile/A10-OLinuXino-Lime
 endef
 
 define Image/Build/Profile/A10-OLinuXino-Lime