dnsmasq: support and use local-service by default (#14951)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 16 Jan 2015 19:04:19 +0000 (19:04 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 16 Jan 2015 19:04:19 +0000 (19:04 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 43982

package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/files/dhcp.conf
package/network/services/dnsmasq/files/dnsmasq.init

index 766aaf04ec1fca308f1859f596d013e7de176cf1..dcbb63a0f3b5b7976220b7da3e82159952984b78 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.72
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 660b06ad4ff8e44e01bb872b6f0a4bd6fef07309..a6e7867ca79a63acc999eb9f3be1800caa0b23fe 100644 (file)
@@ -19,6 +19,7 @@ config dnsmasq
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'
+       option localservice     1  # disable to allow DNS requests from non-loclal subnets
 
 config dhcp lan
        option interface        lan
index 209952b5e68e3944f9e6c3a075e292049fe30603..cb78e831d37aecd02571325ee90204b2eae5b69f 100644 (file)
@@ -127,6 +127,7 @@ dnsmasq() {
        append_bool "$cfg" nonwildcard "--bind-interfaces"
        append_bool "$cfg" fqdn "--dhcp-fqdn"
        append_bool "$cfg" proxydnssec "--proxy-dnssec"
+       append_bool "$cfg" localservice "--local-service"
 
        append_parm "$cfg" dhcpscript "--dhcp-script"
        append_parm "$cfg" cachesize "--cache-size"