Use VBoxManage instead of obsolete vditool to generate VirtualBox images.
authorSteven Barth <cyrus@openwrt.org>
Fri, 2 Jan 2009 14:35:18 +0000 (14:35 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 2 Jan 2009 14:35:18 +0000 (14:35 +0000)
SVN-Revision: 13821

target/linux/x86/image/Config.in
target/linux/x86/image/Makefile

index 6066ba44eff166b535a8cd87f1df0b137fa77134..ef7d0cd855b6d2bf5c8bc01c422756b8844c23fd 100644 (file)
@@ -36,7 +36,7 @@ config X86_GRUB_BOOTOPTS
 
 
 config X86_VDI_IMAGES
-    bool "Build VirtualBox image files (VDI). Requires vditool"
+    bool "Build VirtualBox image files (VDI). Requires VBoxManage"
     depends TARGET_x86
     depends TARGET_ROOTFS_EXT2FS
     depends X86_GRUB_IMAGES
index 9bd2eada6b43fd0083832ae3512e7809f62104f3..839646e547e96231916f754439cb631f0d5d7fa8 100644 (file)
@@ -66,7 +66,7 @@ ifeq ($(CONFIG_X86_VDI_IMAGES),y)
     # left here because the image builder doesnt need these
     ifeq ($(1),ext2)
                rm $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi || true
-               vditool DD $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi $(BIN_DIR)/openwrt-$(BOARD)-ext2.image
+               VBoxManage convertfromraw -format VDI $(BIN_DIR)/openwrt-$(BOARD)-ext2.image $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi
     endif
   endef
 endif
@@ -121,8 +121,8 @@ endef
 $(eval $(call BuildImage))
 
 ifeq ($(CONFIG_X86_VDI_IMAGES),y)
-  $(eval $(call RequireCommand,vditool, \
-       You need vditool to generate VirtualBox images. \
+  $(eval $(call RequireCommand,VBoxManage, \
+       You need VBoxManage to generate VirtualBox images. \
   ))
 endif