ncurses: build host libraries with -fPIC
authorJo-Philipp Wich <jo@mein.io>
Tue, 22 Jan 2019 10:12:04 +0000 (11:12 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 22 Jan 2019 10:29:05 +0000 (11:29 +0100)
Since readline/host links ncurses/host now, we need to ensure that the
libncursesw.so host library is built with -fPIC.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/libs/ncurses/Makefile

index 5d1b28d57d9593a2360116f7e0701995c7cc677e..604a02db52de5d4811a569c379a081c433138da1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncurses
 PKG_VERSION:=6.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -76,6 +76,8 @@ CONFIGURE_ARGS += \
        --enable-widec \
        --with-build-cppflags=-D_GNU_SOURCE
 
+HOST_CFLAGS += $(HOST_FPIC)
+
 HOST_CONFIGURE_ARGS += \
        --without-cxx \
        --without-cxx-binding \