build: force disable stack validation during kernel build on non-linux systems
authorFelix Fietkau <nbd@nbd.name>
Wed, 2 Oct 2019 10:53:09 +0000 (12:53 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 2 Oct 2019 10:55:40 +0000 (12:55 +0200)
The check for libelf in the kernel build is not enough, because the code that
uses libelf for stack validation is completely non-portable, as it tries to
include asm/types.h and relies on kernel types in user space.

Until this is fixed properly, the only solution is to disable this on any non
Linux build host

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/kernel.mk

index 97d23661c9c11672d3a6d0f437e2367875485c29..73645330fe049f5c29ab8909edf2d34fe3d8ea40 100644 (file)
@@ -129,7 +129,8 @@ ifdef CONFIG_USE_SPARSE
   KERNEL_MAKEOPTS += C=1 CHECK=$(STAGING_DIR_HOST)/bin/sparse
 endif
 
-ifeq ($(HOST_OS),Darwin)
+ifneq ($(HOST_OS),Linux)
+  KERNEL_MAKEOPTS += CONFIG_STACK_VALIDATION=
   export SKIP_STACK_VALIDATION:=1
 endif