kernel: bump 5.10 to 5.10.64
authorJohn Audia <graysky@archlinux.us>
Sun, 12 Sep 2021 08:54:32 +0000 (04:54 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Sep 2021 15:08:17 +0000 (17:08 +0200)
All patches automatically rebased.

Build system: x86_64
Build-tested: bcm2711/RPi4B, ipq806x/R7800
Run-tested: bcm2711/RPi4B, ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/apm821xx/patches-5.10/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm27xx/patches-5.10/950-0145-xhci-add-quirk-for-host-controllers-that-don-t-updat.patch
target/linux/bcm27xx/patches-5.10/950-0154-xhci-Use-more-event-ring-segment-table-entries.patch
target/linux/bcm27xx/patches-5.10/950-0355-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
target/linux/bcm27xx/patches-5.10/950-0733-usb-xhci-workaround-for-bogus-SET_DEQ_PENDING-endpoi.patch
target/linux/bcm53xx/patches-5.10/180-usb-xhci-add-support-for-performing-fake-doorbell.patch
target/linux/generic/backport-5.10/610-v5.13-02-netfilter-Fix-fall-through-warnings-for-Clang.patch
target/linux/generic/backport-5.10/610-v5.13-10-netfilter-nftables-update-table-flags-from-the-commi.patch
target/linux/generic/backport-5.10/782-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/generic/hack-5.10/410-block-fit-partition-parser.patch

index ef698b9e432a77375d667f81d4b4b819a2f24a60..925ba44e7b5d8c1467b134365bd630059c62d75c 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .143
-LINUX_VERSION-5.10 = .63
+LINUX_VERSION-5.10 = .64
 
 LINUX_KERNEL_HASH-5.4.143 = 0953650b05a5f806d76c5691583e94e141f4f691bc0ba75a60b643740f021d24
-LINUX_KERNEL_HASH-5.10.63 = 19a15e838885a0081de5f9874e608fc3f3b1d9e69f2cc5cfa883b8b5499bcb2e
+LINUX_KERNEL_HASH-5.10.64 = 3eb84bd24a2de2b4749314e34597c02401c5d6831b055ed5224adb405c35e30a
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 3148e5b465e70f6d34c80ab63eae43a28769f2c7..b9ca1aa92ba7f96ad884620bbe2f0a8e034ed2be 100644 (file)
@@ -43,7 +43,7 @@ produce a noisy warning.
                hcd->msi_enabled = 1;
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1888,6 +1888,7 @@ struct xhci_hcd {
+@@ -1891,6 +1891,7 @@ struct xhci_hcd {
        struct xhci_hub         usb2_rhub;
        struct xhci_hub         usb3_rhub;
        /* support xHCI 1.0 spec USB2 hardware LPM */
index 59a1cf11bd44a80e337bd60ef3ee0b49c0f8241b..aa6daa5634c96b7fe3ce5d873d117bffb7008277 100644 (file)
@@ -80,7 +80,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1881,6 +1881,7 @@ struct xhci_hcd {
+@@ -1884,6 +1884,7 @@ struct xhci_hcd {
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
  #define XHCI_SG_TRB_CACHE_SIZE_QUIRK  BIT_ULL(39)
  #define XHCI_NO_SOFT_RETRY    BIT_ULL(40)
index b80544a16baf9029e59682d015085c11f484f8c7..64bb43e152b901fc434bdfe489071ea815cd83c5 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
                        val);
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1650,8 +1650,8 @@ struct urb_priv {
+@@ -1653,8 +1653,8 @@ struct urb_priv {
   * Each segment table entry is 4*32bits long.  1K seems like an ok size:
   * (1K bytes * 8bytes/bit) / (4*32 bits) = 64 segment entries in the table,
   * meaning 64 ring segments.
index 1e1b9a9510fa47adaadfabc081e27b3e5c434449..9da1275676b39852810b758cecb9dcd608798e7c 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
  
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1882,6 +1882,7 @@ struct xhci_hcd {
+@@ -1885,6 +1885,7 @@ struct xhci_hcd {
  #define XHCI_SG_TRB_CACHE_SIZE_QUIRK  BIT_ULL(39)
  #define XHCI_NO_SOFT_RETRY    BIT_ULL(40)
  #define XHCI_EP_CTX_BROKEN_DCS        BIT_ULL(41)
index 6e43bebf5e8300df7ebf2e404636b60f6188df14..67a7601ac2ea5e13c44612192a5a0adf3018cf48 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -4255,9 +4255,9 @@ void xhci_queue_new_dequeue_state(struct
+@@ -4256,9 +4256,9 @@ void xhci_queue_new_dequeue_state(struct
        }
        ep = &xhci->devs[slot_id]->eps[ep_index];
        if ((ep->ep_state & SET_DEQ_PENDING)) {
index cae6069dfc503c287546b4c1968fe6991173e9e2..36fc3945c7c78781d792cfb4f7b18f6f979fb598 100644 (file)
@@ -127,7 +127,7 @@ it on BCM4708 family.
  /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1881,6 +1881,7 @@ struct xhci_hcd {
+@@ -1884,6 +1884,7 @@ struct xhci_hcd {
  #define XHCI_DISABLE_SPARSE   BIT_ULL(38)
  #define XHCI_SG_TRB_CACHE_SIZE_QUIRK  BIT_ULL(39)
  #define XHCI_NO_SOFT_RETRY    BIT_ULL(40)
index 52d04b051f198d71fcf50d9b84385cdfc4903f88..0aadc2411b9cf000f067ff2856ccce27d12d226b 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        case CT_DCCP_INVALID:
 --- a/net/netfilter/nf_tables_api.c
 +++ b/net/netfilter/nf_tables_api.c
-@@ -8369,6 +8369,7 @@ static int nf_tables_check_loops(const s
+@@ -8394,6 +8394,7 @@ static int nf_tables_check_loops(const s
                                                        data->verdict.chain);
                                if (err < 0)
                                        return err;
index ccfdb9384de3d3c4b8b44aed4c707bb1368186e8..56f68feac82061592469478c7defa8136cdaeec9 100644 (file)
@@ -70,7 +70,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        nft_trans_table_update(trans) = true;
        list_add_tail(&trans->list, &ctx->net->nft.commit_list);
        return 0;
-@@ -7878,11 +7882,10 @@ static int nf_tables_commit(struct net *
+@@ -7903,11 +7907,10 @@ static int nf_tables_commit(struct net *
                switch (trans->msg_type) {
                case NFT_MSG_NEWTABLE:
                        if (nft_trans_table_update(trans)) {
@@ -86,7 +86,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                        } else {
                                nft_clear(net, trans->ctx.table);
                        }
-@@ -8095,11 +8098,9 @@ static int __nf_tables_abort(struct net
+@@ -8120,11 +8123,9 @@ static int __nf_tables_abort(struct net
                switch (trans->msg_type) {
                case NFT_MSG_NEWTABLE:
                        if (nft_trans_table_update(trans)) {
index 6489c037348cdbd82c50c55f97d6bc0f5e536d58..547068ee220066254c07fe5d3ca6fa1ef08eea8e 100644 (file)
@@ -1586,7 +1586,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (!is_valid_ether_addr(ndev->dev_addr))
                eth_hw_addr_random(ndev);
        temac_do_set_mac_address(ndev);
-@@ -1372,7 +1372,7 @@ static int temac_probe(struct platform_d
+@@ -1370,7 +1370,7 @@ static int temac_probe(struct platform_d
        struct device_node *temac_np = dev_of_node(&pdev->dev), *dma_np;
        struct temac_local *lp;
        struct net_device *ndev;
@@ -1595,7 +1595,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        __be32 *p;
        bool little_endian;
        int rc = 0;
-@@ -1563,8 +1563,8 @@ static int temac_probe(struct platform_d
+@@ -1561,8 +1561,8 @@ static int temac_probe(struct platform_d
  
        if (temac_np) {
                /* Retrieve the MAC address */
index ec934728517412f42a030ce2d1e5fcb264d80b32..95067125fb3cc3f9a7221668a235ad5548dc6e99 100644 (file)
@@ -1,6 +1,6 @@
 --- a/block/blk.h
 +++ b/block/blk.h
-@@ -357,6 +357,7 @@ char *disk_name(struct gendisk *hd, int
+@@ -353,6 +353,7 @@ char *disk_name(struct gendisk *hd, int
  #define ADDPART_FLAG_NONE     0
  #define ADDPART_FLAG_RAID     1
  #define ADDPART_FLAG_WHOLEDISK        2