mpc85xx: add input drivers to default packages, and load those during preinit
authorGabor Juhos <juhosg@openwrt.org>
Sat, 16 Feb 2013 17:13:38 +0000 (17:13 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 16 Feb 2013 17:13:38 +0000 (17:13 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35626

target/linux/mpc85xx/Makefile
target/linux/mpc85xx/base-files/lib/preinit/05_mpc85xx_load_input_drivers [new file with mode: 0644]

index c84c0e291150bd4716b63e6c8b2c9fb8ce69607f..feaa3bc7317a04a11e439b46bf50af17b52e9f25 100644 (file)
@@ -17,7 +17,9 @@ LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-booke-wdt
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-booke-wdt
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
diff --git a/target/linux/mpc85xx/base-files/lib/preinit/05_mpc85xx_load_input_drivers b/target/linux/mpc85xx/base-files/lib/preinit/05_mpc85xx_load_input_drivers
new file mode 100644 (file)
index 0000000..ef1cce3
--- /dev/null
@@ -0,0 +1,11 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+
+preinit_mpc85xx_load_input_drivers() {
+       insmod input-core
+       insmod gpio_keys
+       insmod button-hotplug
+}
+
+boot_hook_add preinit_main preinit_mpc85xx_load_input_drivers