mvebu: remove default profile
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Thu, 17 Jan 2019 13:43:36 +0000 (14:43 +0100)
committerMathias Kresin <dev@kresin.me>
Sat, 26 Jan 2019 09:45:34 +0000 (10:45 +0100)
When using Image Builder and building image for Cortex A53 or
A72 subtargets, it'll fail with following message:

Collected errors:
 * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8864.
 * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8964.
make[2]: *** [Makefile:153: package_install] Error 255
make[1]: *** [Makefile:114: _call_image] Error 2

This is beacuse both packages are available only for Cortex A9 subtarget
and are included in PACKAGES array in default profile. Instead patching
this, let's remove profiles completely, since all necessary packages are
specified in DEVICE_PACKAGES array for each device.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
target/linux/mvebu/profiles/000-Default.mk [deleted file]

diff --git a/target/linux/mvebu/profiles/000-Default.mk b/target/linux/mvebu/profiles/000-Default.mk
deleted file mode 100644 (file)
index 8690dd8..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile (all drivers)
-       PACKAGES:= kmod-mwlwifi wpad-basic swconfig mkf2fs e2fsprogs \
-                  mwlwifi-firmware-88w8864 mwlwifi-firmware-88w8964
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-
-$(eval $(call Profile,Default))