package/kernel: move I2C-GPIO drivers from i2c.mk to other.mk
authorGabor Juhos <juhosg@openwrt.org>
Wed, 25 Sep 2013 18:00:33 +0000 (18:00 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 25 Sep 2013 18:00:33 +0000 (18:00 +0000)
Move pca953x support from i2c.mk to other.mk, where other
GPIO drivers are located. Remove duplicate pcf857x support
from i2c.mk.

Signed-off-by: Hartmut Knaack <knaack.h@gmx.de>
[juhosg: update subject, and reformat commit message]
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38185

package/kernel/linux/modules/i2c.mk
package/kernel/linux/modules/other.mk

index f1eea3180739282bb4c057ddb65232403cd2104a..8a26f42e757510af9a732fae0ae06bdb5d87f2b5 100644 (file)
@@ -237,34 +237,3 @@ define KernelPackage/i2c-mux-pca9541/description
 endef
 
 $(eval $(call KernelPackage,i2c-mux-pca9541))
-
-GPIO_PCA953X_MODULES:= \
-  CONFIG_GPIO_PCA953X:drivers/gpio/gpio-pca953x
-
-define KernelPackage/pca953x
-  $(call i2c_defaults,$(GPIO_PCA953X_MODULES),51)
-  TITLE:=Philips PCA953x I2C GPIO extenders
-  DEPENDS:=kmod-i2c-core
-endef
-
-define KernelPackage/pca953x/description
- Kernel modules for PCA953x I2C GPIO extenders
-endef
-
-$(eval $(call KernelPackage,pca953x))
-
-
-GPIO_PCF857X_MODULES:= \
-  CONFIG_GPIO_PCF857X:drivers/gpio/gpio-pcf857x
-
-define KernelPackage/pcf857x
-  $(call i2c_defaults,$(GPIO_PCF857X_MODULES),51)
-  TITLE:=Philips PCF857x I2C GPIO extenders
-  DEPENDS:=kmod-i2c-core
-endef
-
-define KernelPackage/pcf857x/description
- Kernel modules for PCF857x I2C GPIO extenders
-endef
-
-$(eval $(call KernelPackage,pcf857x))
index 15c91207623156437c94eb33a815afd43529e624..b2d59560f332917a19ca7944d287c4c6ae939637 100644 (file)
@@ -162,6 +162,22 @@ endef
 
 $(eval $(call KernelPackage,gpio-nxp-74hc164))
 
+define KernelPackage/gpio-pca953x
+  SUBMENU:=$(OTHER_MENU)
+  DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+  TITLE:=PCA95xx, TCA64xx, and MAX7310 I/O ports
+  KCONFIG:=CONFIG_GPIO_PCA953X
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-pca953x.ko
+  AUTOLOAD:=$(call AutoLoad,55,gpio-pca953x)
+endef
+
+define KernelPackage/gpio-pca953x/description
+ Kernel module for MAX731{0,2,3,5}, PCA6107, PCA953{4-9}, PCA955{4-7},
+ PCA957{4,5} and TCA64{08,16} I2C GPIO expanders
+endef
+
+$(eval $(call KernelPackage,gpio-pca953x))
+
 define KernelPackage/gpio-pcf857x
   SUBMENU:=$(OTHER_MENU)
   DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core