Allow colored output to be disabled when running a non-verbose build by setting NO_CO...
authorLars-Peter Clausen <lars@metafoo.de>
Mon, 8 Feb 2010 22:28:19 +0000 (22:28 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Mon, 8 Feb 2010 22:28:19 +0000 (22:28 +0000)
SVN-Revision: 19560

include/verbose.mk

index 857be24a32e44c9e44c3c759dce7ca881a7eaca2..9fe27ced52f1324adcfba16cdb84d50f65c3089b 100644 (file)
@@ -18,8 +18,10 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:=\\033[33m
-  _N:=\\033[m
+  ifneq ($(strip $(NO_COLOR)),1)
+    _Y:=\\033[33m
+    _N:=\\033[m
+  endif
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)