image.mk: don't squash file permissions in JFFS2 images
authorFlorian Fainelli <florian@openwrt.org>
Tue, 27 Nov 2012 18:42:45 +0000 (18:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 27 Nov 2012 18:42:45 +0000 (18:42 +0000)
Currently we call mkfs.jffs2 --squash, which will change
both file permissions and owners.

If we have some file with suid bits, it will clear these bits.

Thus it's enough to just squash file owners, by replacing that
argument to --squash-uids.

Signed-off-by: Jonh Wendell <jonh.wendell@oiwifi.com.br>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34397

include/image.mk

index 1977fc84c0436cdffd7779d529ef8ea4e11266c5..10850a63271dc772ef147a0544341787cd5608fa 100644 (file)
@@ -18,9 +18,9 @@ KDIR=$(KERNEL_BUILD_DIR)
 IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
 
 ifneq ($(CONFIG_BIG_ENDIAN),)
-  JFFS2OPTS     :=  --pad --big-endian --squash -v
+  JFFS2OPTS     :=  --pad --big-endian --squash-uids -v
 else
-  JFFS2OPTS     :=  --pad --little-endian --squash -v
+  JFFS2OPTS     :=  --pad --little-endian --squash-uids -v
 endif
 
 ifeq ($(CONFIG_JFFS2_RTIME),y)