tools: bootstrap automake to pickup the correct in-tree autoconf
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 13 Jan 2015 07:49:01 +0000 (07:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 13 Jan 2015 07:49:01 +0000 (07:49 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 43958

tools/automake/Makefile

index 300bee21ea116831ffdf5d5f85a916a279c0d2d4..8c390d48de3c596f3e9663f4145d9410669fcd22 100644 (file)
@@ -18,6 +18,11 @@ include $(INCLUDE_DIR)/host-build.mk
 HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
 HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
 
+define Host/Configure
+       (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)
+       $(call Host/Configure/Default)
+endef
+
 define Host/Install
        # remove old automake resources to avoid version conflicts
        rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*