base-file: move alias setup to route hotplug, this fixes alias sections for non-stati...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 1 Jun 2010 21:43:52 +0000 (21:43 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 1 Jun 2010 21:43:52 +0000 (21:43 +0000)
SVN-Revision: 21652

package/base-files/Makefile
package/base-files/files/etc/hotplug.d/iface/10-routes
package/base-files/files/lib/network/config.sh

index 90c804bbe24caaa2a22cc59cd34b8f023052d3d7..158ee2bb2c9513fa84c0b5f8a0e7384e04af8318 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=47
+PKG_RELEASE:=48
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 011668218c300841fc2f0df2c77734367540b9e2..118c1a665dafa60804c08fb4c0d1c7694b17ad29 100644 (file)
@@ -68,7 +68,35 @@ case "$ACTION" in
        ifup)
                include /lib/network
                scan_interfaces
+
+               # Setup aliases
+               config_set "$INTERFACE" aliases ""
+               config_set "$INTERFACE" alias_count 0
+               config_foreach setup_interface_alias alias "$INTERFACE" "$DEVICE"
+
+               # Save alias references in state vars
+               local aliases
+               config_get aliases "$INTERFACE" aliases
+               [ -z "$aliases" ] || uci_set_state network "$INTERFACE" aliases "$aliases"
+
+               # Make ip6addr of parent iface the main address again
+               local ip6addr
+               config_get ip6addr "$INTERFACE" ip6addr
+               [ -z "$ip6addr" ] || {
+                       ifconfig "$DEVICE" del "$ip6addr"
+                       ifconfig "$DEVICE" add "$ip6addr"
+               }
+
+               # Setup routes
                config_foreach "add_route" route
                config_foreach "add_route6" route6
        ;;
+       ifdown)
+               # Bring down named aliases
+               local ifn
+               for ifn in $(ifconfig | sed -ne "s/^\($DEVICE:[^[:space:]]\+\).*/\1/p"); do
+                       ifconfig "$ifn" down
+               done
+       ;;
 esac
+
index 1bb3a46ecd133f428138051d39854a264d287c2c..a31e83688fe23848fca3ff6020eff8f592fe8559 100755 (executable)
@@ -275,49 +275,47 @@ setup_interface_alias() {
 }
 
 setup_interface() {
-       local iface_main="$1"
+       local iface="$1"
        local config="$2"
        local proto="$3"
        local vifmac="$4"
-       local ip6addr_main=
 
        [ -n "$config" ] || {
-               config=$(find_config "$iface_main")
+               config=$(find_config "$iface")
                [ "$?" = 0 ] || return 1
        }
 
-       prepare_interface "$iface_main" "$config" "$vifmac" || return 0
+       prepare_interface "$iface" "$config" "$vifmac" || return 0
 
-       [ "$iface_main" = "br-$config" ] && {
+       [ "$iface" = "br-$config" ] && {
                # need to bring up the bridge and wait a second for
                # it to switch to the 'forwarding' state, otherwise
                # it will lose its routes...
-               ifconfig "$iface_main" up
+               ifconfig "$iface" up
                sleep 1
        }
 
        # Interface settings
-       grep "$iface_main:" /proc/net/dev > /dev/null && {
+       grep "$iface:" /proc/net/dev > /dev/null && {
                local mtu macaddr
                config_get mtu "$config" mtu
                config_get macaddr "$config" macaddr
-               [ -n "$macaddr" ] && $DEBUG ifconfig "$iface_main" down
-               $DEBUG ifconfig "$iface_main" ${macaddr:+hw ether "$macaddr"} ${mtu:+mtu $mtu} up
+               [ -n "$macaddr" ] && $DEBUG ifconfig "$iface" down
+               $DEBUG ifconfig "$iface" ${macaddr:+hw ether "$macaddr"} ${mtu:+mtu $mtu} up
        }
-       set_interface_ifname "$config" "$iface_main"
+       set_interface_ifname "$config" "$iface"
 
        [ -n "$proto" ] || config_get proto "$config" proto
        case "$proto" in
                static)
-                       config_get ip6addr_main "$config" ip6addr
-                       setup_interface_static "$iface_main" "$config"
+                       setup_interface_static "$iface" "$config"
                ;;
                dhcp)
-                       local lockfile="/var/lock/dhcp-$iface_main"
+                       local lockfile="/var/lock/dhcp-$iface"
                        lock "$lockfile"
 
                        # prevent udhcpc from starting more than once
-                       local pidfile="/var/run/dhcp-${iface_main}.pid"
+                       local pidfile="/var/run/dhcp-${iface}.pid"
                        local pid="$(cat "$pidfile" 2>/dev/null)"
                        if [ -d "/proc/$pid" ] && grep -qs udhcpc "/proc/${pid}/cmdline"; then
                                lock -u "$lockfile"
@@ -330,45 +328,27 @@ setup_interface() {
                                config_get clientid "$config" clientid
 
                                [ -z "$ipaddr" ] || \
-                                       $DEBUG ifconfig "$iface_main" "$ipaddr" ${netmask:+netmask "$netmask"}
+                                       $DEBUG ifconfig "$iface" "$ipaddr" ${netmask:+netmask "$netmask"}
 
                                # don't stay running in background if dhcp is not the main proto on the interface (e.g. when using pptp)
                                local dhcpopts
                                [ ."$proto1" != ."$proto" ] && dhcpopts="-n -q"
-                               $DEBUG eval udhcpc -t 0 -i "$iface_main" ${ipaddr:+-r $ipaddr} ${hostname:+-H $hostname} ${clientid:+-c $clientid} -b -p "$pidfile" ${dhcpopts:- -O rootpath -R &}
+                               $DEBUG eval udhcpc -t 0 -i "$iface" ${ipaddr:+-r $ipaddr} ${hostname:+-H $hostname} ${clientid:+-c $clientid} -b -p "$pidfile" ${dhcpopts:- -O rootpath -R &}
                                lock -u "$lockfile"
                        fi
                ;;
                none)
-                       setup_interface_none "$iface_main" "$config"
+                       setup_interface_none "$iface" "$config"
                ;;
                *)
                        if ( eval "type setup_interface_$proto" ) >/dev/null 2>/dev/null; then
-                               eval "setup_interface_$proto '$iface_main' '$config' '$proto'"
+                               eval "setup_interface_$proto '$iface' '$config' '$proto'"
                        else
                                echo "Interface type $proto not supported."
                                return 1
                        fi
                ;;
        esac
-       [ "$proto" = none ] || {
-               for ifn in `ifconfig | grep "^$iface_main:" | awk '{print $1}'`; do
-                       ifconfig "$ifn" down
-               done
-       }
-
-       local aliases
-       config_set "$config" aliases ""
-       config_set "$config" alias_count 0
-       config_foreach setup_interface_alias alias "$config" "$iface_main"
-       config_get aliases "$config" aliases
-       [ -z "$aliases" ] || uci_set_state network "$config" aliases "$aliases"
-
-       # put the ip6addr back to the beginning to become the main ip again
-       [ -z "$ip6addr_main" ] || {
-               $DEBUG ifconfig "$iface_main" del "$ip6addr_main"
-               $DEBUG ifconfig "$iface_main" add "$ip6addr_main"
-       }
 }
 
 stop_interface_dhcp() {