ep93xx: remove obsolete kernel version check
authorFelix Fietkau <nbd@openwrt.org>
Sat, 24 Jan 2015 22:13:17 +0000 (22:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 24 Jan 2015 22:13:17 +0000 (22:13 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 44112

target/linux/ep93xx/modules.mk

index 429546690f6171dff6c5dac50901ac6f30d3b517..07726c950938f35540a887fd9cd6f8e3903846d4 100644 (file)
@@ -39,18 +39,12 @@ endef
 
 $(eval $(call KernelPackage,input-keyboard-ep93xx))
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.8.0)),1)
-SND_EP93XX_SOC_DIR:=cirrus
-else
-SND_EP93XX_SOC_DIR:=ep93xx
-endif
-
 define KernelPackage/sound-soc-ep93xx
   SUBMENU:=$(SOUND_MENU)
   TITLE:=EP93xx SoC sound support
   DEPENDS:=@TARGET_ep93xx +kmod-sound-core +kmod-sound-soc-core
   KCONFIG:=CONFIG_SND_EP93XX_SOC
-  FILES:=$(LINUX_DIR)/sound/soc/$(SND_EP93XX_SOC_DIR)/snd-soc-ep93xx.ko
+  FILES:=$(LINUX_DIR)/sound/soc/cirrus/snd-soc-ep93xx.ko
   AUTOLOAD:=$(call AutoLoad,57,snd-soc-ep93xx)
 endef