Fix compilation of crypto modules. This fixes #7920
authorMichael Büsch <mb@bu3sch.de>
Sun, 12 Sep 2010 15:31:00 +0000 (15:31 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sun, 12 Sep 2010 15:31:00 +0000 (15:31 +0000)
SVN-Revision: 23028

package/kernel/modules/crypto.mk

index 1ec540be1b381986b5a46f2dfe3b998f23a35980..3be3afdcaa212c94e059ed1524a01414c46b9f66 100644 (file)
@@ -22,9 +22,9 @@ SHA256_SUFFIX:=$(CRYPTO_GENERIC)
 SHA512_SUFFIX:=$(CRYPTO_GENERIC)
 
 CRYPTO_MODULES = \
-       $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),ALGAPI2,ALGAPI)=crypto_algapi \
+       $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),ALGAPI2,ALGAPI)=crypto_algapi \
        AEAD2=aead \
-       $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)=pcompress \
+       $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)=pcompress \
        BLKCIPHER2=crypto_blkcipher \
        HASH2=crypto_hash \
        MANAGER2=cryptomgr \