Package AHCI driver
authorAndy Boyett <agb@openwrt.org>
Mon, 12 May 2008 06:40:37 +0000 (06:40 +0000)
committerAndy Boyett <agb@openwrt.org>
Mon, 12 May 2008 06:40:37 +0000 (06:40 +0000)
SVN-Revision: 11119

package/kernel/modules/block.mk

index 52b9bc6596e1a5fa52b3200352ce57ea903cc556..db5f3528651f810aad36ab7a5ffead1f09c8cf6b 100644 (file)
@@ -20,6 +20,22 @@ endef
 $(eval $(call KernelPackage,ata-core))
 
 
+define KernelPackage/ata-ahci
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=AHCI Serial ATA support
+  DEPENDS:=kmod-ata-core
+  KCONFIG:=CONFIG_SATA_AHCI
+  FILES:=$(LINUX_DIR)/drivers/ata/ahci.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,ahci)
+endef
+
+define KernelPackage/ata-ahci/description
+ Support for AHCI Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-ahci))
+
+
 define KernelPackage/ata-artop
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=ARTOP 6210/6260 PATA support
@@ -52,6 +68,7 @@ endef
 $(eval $(call KernelPackage,ata-ixp4xx-cf))
 
 
+
 define KernelPackage/ata-piix
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Intel PIIX PATA/SATA support