kernel/acx-mac80211: fix autoloading on boot
authorJonas Gorski <jogo@openwrt.org>
Thu, 11 Dec 2014 19:35:36 +0000 (19:35 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 11 Dec 2014 19:35:36 +0000 (19:35 +0000)
The kernel build system cannot track dependencies of out-of-tree
modules, making the buildsystem fail to load mac80211.

Add mac80211 as an explicit load to ensure all required modules are
loaded.

Fixes #16522.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 43631

package/kernel/acx-mac80211/Makefile

index 16f6f5d06ed6edcfb498508b89639c514141996e..dfb73f71b821d83b879bff5ae92ef9e7fa01341d 100644 (file)
@@ -32,7 +32,7 @@ define KernelPackage/acx-mac80211
   TITLE:=ACX1xx mac80211 driver
   DEPENDS:=@(PCI_SUPPORT||TARGET_ar7) @mipsel +kmod-mac80211
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.ko
-  AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
+  AUTOLOAD:=$(call AutoLoad,50,mac80211 acx-mac80211)
   MAINTAINER:=Florian Fainelli <florian@openwrt.org>
   MENU:=1
 endef