flex: fix build error due to undefined library symbols
authorFelix Fietkau <nbd@openwrt.org>
Wed, 12 Mar 2014 10:47:31 +0000 (10:47 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 12 Mar 2014 10:47:31 +0000 (10:47 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 39888

tools/Makefile
tools/flex/patches/100-remove_no_undefined.patch [new file with mode: 0644]

index 7466b82e4bbec83e9b9ed4db357b2b877b68c9f7..428cf0bedbf00b6f18ae9bd6ebbb0172cb7890c2 100644 (file)
@@ -41,7 +41,7 @@ tools-$(BUILD_PPL_CLOOG) += ppl cloog
 
 # builddir dependencies
 $(curdir)/bison/compile := $(curdir)/flex/install
-$(curdir)/flex/compile := $(curdir)/m4/install
+$(curdir)/flex/compile := $(curdir)/automake/install
 $(curdir)/pkg-config/compile := $(curdir)/sed/install
 $(curdir)/libtool/compile := $(curdir)/sed/install
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/install
diff --git a/tools/flex/patches/100-remove_no_undefined.patch b/tools/flex/patches/100-remove_no_undefined.patch
new file mode 100644 (file)
index 0000000..4e8aca1
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -73,13 +73,13 @@ libfl_la_SOURCES = \
+       libmain.c \
+       libyywrap.c
+-libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+ libfl_pic_la_SOURCES = \
+       libmain.c \
+       libyywrap.c
+-libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_pic_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+ noinst_HEADERS = \
+       flexdef.h \