kernel: add package for usbport LED trigger
authorRafał Miłecki <rafal@milecki.pl>
Tue, 4 Oct 2016 10:32:13 +0000 (12:32 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Tue, 18 Oct 2016 12:27:14 +0000 (14:27 +0200)
This is upstream alternative for LEDE's ledtrig-usbdev. It's main
advantages are:
1) Support for assigning more than 1 USB port to the LED
2) Setting proper state when activating with device already connected
3) FWIW it's an upstream driver

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/kernel/linux/modules/usb.mk

index d25f7c10c8fbe54a37be51113b7ab9cc7ef03b80..5f90e86ebc696737d7f5f91187124669da807338 100644 (file)
@@ -36,6 +36,25 @@ define AddDepends/usb
 endef
 
 
+define KernelPackage/usb-ledtrig-usbport
+  TITLE:=LED trigger for USB ports
+  KCONFIG:=CONFIG_USB_LEDS_TRIGGER_USBPORT
+  DEPENDS:=@!LINUX_3_18
+  FILES:=$(LINUX_DIR)/drivers/usb/core/ledtrig-usbport.ko
+  AUTOLOAD:=$(call AutoLoad,50,ledtrig-usbport)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-ledtrig-usbport/description
+  This driver allows LEDs to be controlled by USB events. Enabling this
+  trigger allows specifying list of USB ports that should turn on LED
+  when some USB device gets connected.
+  If possible it should be prefered over similar ledtrig-usbdev.
+endef
+
+$(eval $(call KernelPackage,usb-ledtrig-usbport))
+
+
 define KernelPackage/usb-musb-hdrc
   TITLE:=Support for Mentor Graphics silicon dual role USB
   KCONFIG:= \