fstools: stage libubi-utils static library and headers
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:44:16 +0000 (12:44 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:44:16 +0000 (12:44 +0000)
Use InstallDev to make libubi-utils available for linking in
uboot-envtools.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 40928

package/system/fstools/Makefile

index 40adf0af5725b60ecad8e0812178b0305e7053ee..b10f105a741f7bdd830869960a1ca950bd39ab84 100644 (file)
@@ -78,6 +78,13 @@ define Package/block-mount/install
 
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libubi-utils.a $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,fstools))
 $(eval $(call BuildPackage,ubi-flash))
 $(eval $(call BuildPackage,block-mount))