kernel: video-core depends on i2c-core if i2c-core is selected
authorJonas Gorski <jogo@openwrt.org>
Thu, 18 Jul 2013 20:40:17 +0000 (20:40 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 18 Jul 2013 20:40:17 +0000 (20:40 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 37421

package/kernel/linux/modules/video.mk

index e652e8a4f0e89b1b30a8665eb26d1ddb2d7ec897..def8d48b6e7d72f3a5123d80851e28a6ec66245b 100644 (file)
@@ -82,7 +82,7 @@ $(eval $(call KernelPackage,fb-cfb-imgblt))
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
   TITLE=Video4Linux support
-  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT +PACKAGE_kmod-i2c-core:kmod-i2c-core
   KCONFIG:= \
        CONFIG_MEDIA_SUPPORT=m \
        CONFIG_MEDIA_CAMERA_SUPPORT=y \