revert threadsafe patch
authorJohn Crispin <john@openwrt.org>
Wed, 29 Aug 2012 10:08:30 +0000 (10:08 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 29 Aug 2012 10:08:30 +0000 (10:08 +0000)
SVN-Revision: 33292

package/openssl/Makefile

index 123f393d5a47e754055808770ca2ab78745b1c9f..d95783aac95d88927e97ac2fae7a331d857c9750 100644 (file)
@@ -58,7 +58,7 @@ define Package/openssl-util
   $(call Package/openssl/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libopenssl +libpthread
+  DEPENDS:=+libopenssl
   TITLE+= (utility)
 endef
 
@@ -105,7 +105,7 @@ define Build/Configure
        )
 endef
 
-TARGET_CFLAGS += $(FPIC) -DOPENSSL_THREADS -pthread -D_REENTRANT -D_THREAD_SAFE -D_THREADSAFE
+TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
        # XXX: OpenSSL "make depend" will look for installed headers before its own,