cURL: Update to version 7.40.0
authorJohn Crispin <john@openwrt.org>
Wed, 28 Jan 2015 12:07:47 +0000 (12:07 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 28 Jan 2015 12:07:47 +0000 (12:07 +0000)
* Update to version 7.40.0
* remove non existing config options around enable/disable HTTPS protocoll
* remove --with-ca-path if ssl support disabled
* set proxy support as default like all versions before CC did

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
SVN-Revision: 44176

package/network/utils/curl/Config.in
package/network/utils/curl/Makefile
package/network/utils/curl/patches/100-check_long_long.patch
package/network/utils/curl/patches/200-no_docs_tests.patch

index 026dcd68042f66d89d5f8edb752971cb283e4b99..87e5f99f577d83c62087c7b9009b40ed1e904c88 100644 (file)
@@ -1,5 +1,4 @@
-menu "Configuration"
-       depends on PACKAGE_libcurl
+if PACKAGE_libcurl
 
 choice
        prompt "SSL library"
@@ -53,10 +52,6 @@ config LIBCURL_HTTP
        bool "Enable HTTP support"
        default y
 
-config LIBCURL_HTTPS
-       bool "Enable HTTPS support"
-       default n
-
 config LIBCURL_IMAP
        bool "Enable IMAP support"
        default n
@@ -79,7 +74,7 @@ config LIBCURL_POP3
 
 config LIBCURL_PROXY
        bool "Enable proxy support"
-       default n
+       default y
 
 config LIBCURL_RTSP
        bool "Enable RTSP support"
@@ -113,4 +108,4 @@ config LIBCURL_ZLIB
        bool "Use zlib"
        default n
 
-endmenu
+endif
index 1a374951c1e50a798a2e8b5d0109312497d0803d..08e2f1d1e94e9492c64dabffb8dbb24b0d7ae3ce 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.38.0
+PKG_VERSION:=7.40.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=af6b3c299bd891f43cb5f76c4091b7b4
+PKG_MD5SUM:=8d30594212e65657a5c32030f0998fa9
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
@@ -37,7 +37,6 @@ PKG_CONFIG_DEPENDS := \
   LIBCURL_GNUTLS \
   LIBCURL_GOPHER \
   LIBCURL_HTTP \
-  LIBCURL_HTTPS \
   LIBCURL_IMAP \
   LIBCURL_LDAP \
   LIBCURL_LDAPS \
@@ -98,7 +97,7 @@ CONFIGURE_ARGS += \
        --disable-manual \
        --disable-verbose \
        --without-ca-bundle \
-       $(if $(CONFIG_LIBCURL_OPENSSL),--with-ca-path=/etc/ssl/certs/) \
+       $(if $(CONFIG_LIBCURL_NOSSL),,--with-ca-path=/etc/ssl/certs/) \
        --without-krb4 \
        --without-libidn \
        --without-nss \
@@ -114,7 +113,6 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LIBCURL_GOPHER),--enable,--disable)-gopher \
        $(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr",--without-gnutls) \
        $(if $(CONFIG_LIBCURL_HTTP),--enable,--disable)-http \
-       $(if $(CONFIG_LIBCURL_HTTPS),--enable,--disable)-https \
        $(if $(CONFIG_LIBCURL_IMAP),--enable,--disable)-imap \
        $(if $(CONFIG_LIBCURL_LDAP),--enable,--disable)-ldap \
        $(if $(CONFIG_LIBCURL_LDAPS),--enable,--disable)-ldaps \
index 05fb1bfb978957d554d43fd839d93c1aa668de0b..2dd8cc72d8cd3813abc0b2a9fb05fa2a8aaca07f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2877,6 +2877,7 @@ CURL_VERIFY_RUNTIMELIBS
+@@ -2885,6 +2885,7 @@ CURL_VERIFY_RUNTIMELIBS
  
  AC_CHECK_SIZEOF(size_t)
  AC_CHECK_SIZEOF(long)
index 42619a3840d258a66f3618c598f8c6c535cedef9..6a1fdf5b6b29da620dc6e0b302840a68dbfbd025 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -128,7 +128,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -129,7 +129,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP) $(VC7_LIBVCPROJ) $(VC7_SRCVCPROJ) \
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src include
@@ -11,7 +11,7 @@
  pkgconfig_DATA = libcurl.pc
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -574,7 +574,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -577,7 +577,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP) $(VC7_LIBVCPROJ) $(VC7_SRCVCPROJ) \
  
  bin_SCRIPTS = curl-config
  SUBDIRS = lib src include
@@ -19,4 +19,4 @@
 +DIST_SUBDIRS = $(SUBDIRS) packages
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
- LIB_VTLS_CFILES = vtls/openssl.c vtls/gtls.c vtls/vtls.c vtls/nss.c   \
+ LIB_VTLS_CFILES = vtls/openssl.c vtls/gtls.c vtls/vtls.c vtls/nss.c     \