sysupgrade: install /bin/sleep into ramdisk too and add completition notice (#4747)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Mar 2009 00:21:25 +0000 (00:21 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Mar 2009 00:21:25 +0000 (00:21 +0000)
SVN-Revision: 14784

package/base-files/Makefile
package/base-files/files/lib/upgrade/common.sh

index 437952d72fe1b2b842e611533e8a1677d62c1441..33e8237819865e2debb467179e134509f06059ee 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=15
+PKG_RELEASE:=16
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index cf8977a5f2c0cd5373c87ebd205b3f36e7571033..d4fb04ba97e89e343c250cd1a85908a9f40be70a 100644 (file)
@@ -45,7 +45,7 @@ pivot() { # <new_root> <old_root>
 }
 
 run_ramfs() { # <command> [...]
-       install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump
+       install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump /bin/sleep
        install_bin /sbin/mtd
        for file in $RAMFS_COPY_BIN; do
                install_bin $file
@@ -160,6 +160,7 @@ do_upgrade() {
                        jffs2_copy_config
                fi
        }
+       v "Upgrade completed"
        [ -n "$DELAY" ] && sleep "$DELAY"
        ask_bool 1 "Reboot" && reboot
 }