ath79: fix boardname of GL.iNet GL-AR150
authorPaul Wassi <p.wassi@gmx.at>
Sun, 30 Dec 2018 20:37:50 +0000 (21:37 +0100)
committerMathias Kresin <dev@kresin.me>
Mon, 31 Dec 2018 13:05:26 +0000 (14:05 +0100)
This device is called GL-AR150, therefore rename the board
to 'gl-ar150'

Signed-off-by: Paul Wassi <p.wassi@gmx.at>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/ar9330_glinet_ar150.dts [deleted file]
target/linux/ath79/dts/ar9330_glinet_gl-ar150.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index 83bede0961d46e61ea1c54b3f87f5b84d4d725a2..906ccd753fee56a8d6a0fd6a6cc79608061c849b 100755 (executable)
@@ -89,8 +89,8 @@ ath79_setup_interfaces()
        etactica,eg200)
                ucidef_set_interface_lan "eth0" "dhcp"
                ;;
-       glinet,ar150|\
        glinet,ar300m|\
+       glinet,gl-ar150|\
        glinet,gl-x750)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
                ;;
diff --git a/target/linux/ath79/dts/ar9330_glinet_ar150.dts b/target/linux/ath79/dts/ar9330_glinet_ar150.dts
deleted file mode 100644 (file)
index fbc3acd..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9330.dtsi"
-
-/ {
-       model = "GL.iNet GL-AR150";
-       compatible = "glinet,ar150", "qca,ar9330";
-
-       aliases {
-               serial0 = &uart;
-               led-boot = &wlan;
-               led-failsafe = &wlan;
-               led-upgrade = &wlan;
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               wlan: wlan {
-                       label = "gl-ar150:orange:wlan";
-                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
-                       linux,default-trigger = "phy0tpt";
-               };
-
-               lan {
-                       label = "gl-ar150:green:lan";
-                       gpios = <&gpio 13 GPIO_ACTIVE_HIGH>;
-               };
-
-               wan {
-                       label = "gl-ar150:green:wan";
-                       gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               poll-interval = <100>;
-
-               manual {
-                       label = "manual";
-                       linux,code = <BTN_7>;
-                       gpios = <&gpio 7 GPIO_ACTIVE_HIGH>;
-               };
-
-               auto {
-                       label = "auto";
-                       linux,code = <BTN_8>;
-                       gpios = <&gpio 8 GPIO_ACTIVE_HIGH>;
-               };
-
-               reset {
-                       label = "reset";
-                       linux,code = <KEY_RESTART>;
-                       gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
-               };
-       };
-};
-
-&uart {
-       status = "okay";
-};
-
-&gpio {
-       status = "okay";
-};
-
-&usb {
-       dr_mode = "host";
-       status = "okay";
-};
-
-&usb_phy {
-       status = "okay";
-       gpios = <&gpio 6 GPIO_ACTIVE_HIGH>;
-};
-
-&spi {
-       num-chipselects = <1>;
-       status = "okay";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               spi-max-frequency = <104000000>;
-               reg = <0>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x040000>;
-                               read-only;
-                       };
-
-                       partition@1 {
-                               label = "u-boot-env";
-                               reg = <0x040000 0x010000>;
-                       };
-
-                       partition@2 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x050000 0xfa0000>;
-                       };
-
-                       art: partition@3 {
-                               label = "ART";
-                               reg = <0xff0000 0x010000>;
-                               read-only;
-                       };
-               };
-       };
-};
-
-&eth0 {
-       status = "okay";
-
-       mtd-mac-address = <&art 0x0>;
-};
-
-&eth1 {
-       status = "okay";
-
-       mtd-mac-address = <&art 0x0>;
-
-       gmac-config {
-               device = <&gmac>;
-
-               switch-phy-addr-swap = <0>;
-               switch-phy-swap = <0>;
-       };
-};
-
-&wmac {
-       status = "okay";
-       mtd-cal-data = <&art 0x1000>;
-       mtd-mac-address = <&art 0x0>;
-};
diff --git a/target/linux/ath79/dts/ar9330_glinet_gl-ar150.dts b/target/linux/ath79/dts/ar9330_glinet_gl-ar150.dts
new file mode 100644 (file)
index 0000000..53df367
--- /dev/null
@@ -0,0 +1,145 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9330.dtsi"
+
+/ {
+       model = "GL.iNet GL-AR150";
+       compatible = "glinet,gl-ar150", "qca,ar9330";
+
+       aliases {
+               serial0 = &uart;
+               led-boot = &wlan;
+               led-failsafe = &wlan;
+               led-upgrade = &wlan;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               wlan: wlan {
+                       label = "gl-ar150:orange:wlan";
+                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               lan {
+                       label = "gl-ar150:green:lan";
+                       gpios = <&gpio 13 GPIO_ACTIVE_HIGH>;
+               };
+
+               wan {
+                       label = "gl-ar150:green:wan";
+                       gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <100>;
+
+               manual {
+                       label = "manual";
+                       linux,code = <BTN_7>;
+                       gpios = <&gpio 7 GPIO_ACTIVE_HIGH>;
+               };
+
+               auto {
+                       label = "auto";
+                       linux,code = <BTN_8>;
+                       gpios = <&gpio 8 GPIO_ACTIVE_HIGH>;
+               };
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&gpio {
+       status = "okay";
+};
+
+&usb {
+       dr_mode = "host";
+       status = "okay";
+};
+
+&usb_phy {
+       status = "okay";
+       gpios = <&gpio 6 GPIO_ACTIVE_HIGH>;
+};
+
+&spi {
+       num-chipselects = <1>;
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <104000000>;
+               reg = <0>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@1 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@2 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x050000 0xfa0000>;
+                       };
+
+                       art: partition@3 {
+                               label = "ART";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x0>;
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x0>;
+
+       gmac-config {
+               device = <&gmac>;
+
+               switch-phy-addr-swap = <0>;
+               switch-phy-swap = <0>;
+       };
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&art 0x0>;
+};
index 31c62f659d291be79f14badbd00c46ecf4558ad9..600ab43e7f905ba18a80848e06395afb09acd9e3 100644 (file)
@@ -259,14 +259,14 @@ define Device/etactica_eg200
 endef
 TARGET_DEVICES += etactica_eg200
 
-define Device/glinet_ar150
+define Device/glinet_gl-ar150
   ATH_SOC := ar9330
   DEVICE_TITLE := GL.iNet GL-AR150
   DEVICE_PACKAGES := kmod-usb-chipidea2
   IMAGE_SIZE := 16000k
   SUPPORTED_DEVICES += gl-ar150
 endef
-TARGET_DEVICES += glinet_ar150
+TARGET_DEVICES += glinet_gl-ar150
 
 define Device/glinet_ar300m-nor
   ATH_SOC := qca9531