ar71xx: move some always-used led related functionality from kmod packages to the...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 7 Apr 2014 10:44:52 +0000 (10:44 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 7 Apr 2014 10:44:52 +0000 (10:44 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40413

target/linux/ar71xx/Makefile
target/linux/ar71xx/config-3.10

index fe54a523431b03be55ffee93e903c7f3cf113ccd..25c51c33efa44b29fadf1b84884f6ed3c5b38cf6 100644 (file)
@@ -18,8 +18,7 @@ LINUX_VERSION:=3.10.34
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+       kmod-gpio-button-hotplug swconfig \
        kmod-ath9k wpad-mini uboot-envtools
 
 $(eval $(call BuildTarget))
index f4d1fd8ff40ecf46b9608bcfa4c732ed12e01b6c..10817ea578d8d91a33a40535ef7a6511c1391f6c 100644 (file)
@@ -196,9 +196,7 @@ CONFIG_IRQ_CPU=y
 CONFIG_IRQ_DOMAIN=y
 CONFIG_IRQ_FORCED_THREADING=y
 CONFIG_IRQ_WORK=y
-# CONFIG_LEDS_TRIGGER_DEFAULT_ON is not set
-# CONFIG_LEDS_TRIGGER_NETDEV is not set
-# CONFIG_LEDS_TRIGGER_TIMER is not set
+CONFIG_LEDS_GPIO=y
 # CONFIG_LEDS_WNDR3700_USB is not set
 # CONFIG_M25PXX_USE_FAST_READ is not set
 CONFIG_MARVELL_PHY=y