ralink: add support for netis WF-2881
authorJohn Crispin <john@openwrt.org>
Tue, 24 Nov 2015 18:29:26 +0000 (18:29 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 24 Nov 2015 18:29:26 +0000 (18:29 +0000)
netis WF-2881 is an MT7621AT based router with MT7602EN, MT7612EN.
It has 128MB DDR3, 128MB SLC NAND FLASH, 5-port Gbps switch and 1x USB 3.0.
The following patch adds support for this device.

this device only works on top of UBI.

Tested and working:
* ethernet
* both WiFi radios
* USB 3.0
* buttons (reset button)
* ethernet switch and USB diag LEDs
* UART
* GPIOs
* sysupgrade

Tested and not working
* failsafe

Signed-off-by: YounJae Rho <luxflow@live.com>
SVN-Revision: 47619

target/linux/ramips/Makefile
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WF-2881.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7621/config-3.18
target/linux/ramips/mt7621/profiles/netis.mk [new file with mode: 0644]

index eafd2742e6aa086f5017406ce8416530d425caa7..a92b287fcf36697ee90d72a5de8b7d1c86548c40 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
-FEATURES:=squashfs gpio
+FEATURES:=squashfs gpio ubifs
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 KERNEL_PATCHVER:=3.18
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 KERNEL_PATCHVER:=3.18
index 1c18ded505e2f65ed5c304ac99bdb85dac75eb8a..a4658a01b18223047f04c06d1ca57d58b11bc1ab 100755 (executable)
@@ -44,7 +44,8 @@ air3gii)
 all0239-3g|\
 hw550-3g|\
 mofi3500-3gn|\
 all0239-3g|\
 hw550-3g|\
 mofi3500-3gn|\
-sap-g3200u3)
+sap-g3200u3|\
+wf-2881)
        set_usb_led "$board:green:usb"
        ;;
 all0256n)
        set_usb_led "$board:green:usb"
        ;;
 all0256n)
index 22809d1720ae3ff374a724c99fdf06557e101ce6..7e5122986c564b7571c9f59cf1c03cd74ccccd5f 100755 (executable)
@@ -78,6 +78,7 @@ ramips_setup_interfaces()
        oy-0001|\
        pbr-m1|\
        sap-g3200u3|\
        oy-0001|\
        pbr-m1|\
        sap-g3200u3|\
+       wf-2881|\
        whr-300hp2|\
        whr-600d|\
        wsr-1166|\
        whr-300hp2|\
        whr-600d|\
        wsr-1166|\
index 3013d245d62a80d773028c504e0754bc5c0c9709..ff5fbf26969570f1fc07249da6b0c534692583ff 100644 (file)
@@ -155,6 +155,7 @@ get_status_led() {
        tew-692gr|\
        ur-326n4g|\
        ur-336un|\
        tew-692gr|\
        ur-326n4g|\
        ur-336un|\
+       wf-2881|\
        wr512-3gn)
                status_led="$board:green:wps"
                ;;
        wr512-3gn)
                status_led="$board:green:wps"
                ;;
index d6fdeb9891bd5a3184785fc06dfbc3598f937c16..92e13c034fb65f9a91283dfe66dce9f965bfdbeb 100755 (executable)
@@ -376,6 +376,9 @@ ramips_board_detect() {
        *"WCR-150GN")
                name="wcr-150gn"
                ;;
        *"WCR-150GN")
                name="wcr-150gn"
                ;;
+       *"WF-2881")
+               name="wf-2881"
+               ;;
        *"WHR-1166D")
                name="whr-1166d"
                ;;
        *"WHR-1166D")
                name="whr-1166d"
                ;;
index 0b9dd43791c1f0a364e470ae5cf341914e4e791a..073593ad38f4e0a6fc791d97068565ead48badcd 100755 (executable)
@@ -108,6 +108,7 @@ platform_check_image() {
        w150m|\
        w306r-v20|\
        w502u|\
        w150m|\
        w306r-v20|\
        w502u|\
+       wf-2881|\
        whr-1166d|\
        whr-300hp2|\
        whr-600d|\
        whr-1166d|\
        whr-300hp2|\
        whr-600d|\
diff --git a/target/linux/ramips/dts/WF-2881.dts b/target/linux/ramips/dts/WF-2881.dts
new file mode 100644 (file)
index 0000000..7228dc5
--- /dev/null
@@ -0,0 +1,133 @@
+/dts-v1/;
+
+/include/ "mt7621.dtsi"
+
+/ {
+       compatible = "mediatek,mt7621-eval-board", "mediatek,mt7621-soc";
+       model = "NETIS WF-2881";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x8000000>;
+       };
+
+       palmbus@1E000000 {
+               spi@b00 {
+                       status="disabled";
+               };
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       nand@1e003000 {
+               compatible = "mtk,mt7621-nand";
+               bank-width = <2>;
+               reg = <0x1e003000 0x800
+                               0x1e003800 0x800>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x1000>;
+                       read-only;
+               };
+
+               partition@80000 {
+                       label = "config";
+                       reg = <0x80000 0x80000>;
+                       read-only;
+               };
+
+               factory: partition@100000 {
+                       label = "factory";
+                       reg = <0x100000 0x40000>;
+                       read-only;
+               };
+
+               firmware {
+                       label = "firmware";
+                       reg = <0x140000 0x6EC0000>;
+               };
+
+               partition@140000 {
+                       label = "kernel";
+                       reg = <0x140000 0x200000>;
+               };
+
+               partition@340000 {
+                       label = "ubi";
+                       reg = <0x340000 0x6CC0000>;
+               };
+       };
+
+       pcie@1e140000 {
+               status = "okay";
+
+               pcie0 {
+                       mt76@0,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x8000>;
+                               mediatek,2ghz = <0>;
+                       };
+               };
+
+               pcie1 {
+                       mt76@1,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x0000>;
+                               mediatek,5ghz = <0>;
+                       };
+               };
+       };
+
+       ethernet@1e100000 {
+               mtd-mac-address = <&factory 0xe006>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               usb {
+                       label = "wf-2881:green:usb";
+                       gpios = <&gpio0 6 1>;
+               };
+
+               wps {
+                       label = "wf-2881:green:wps";
+                       gpios = <&gpio0 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 12 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "uart3", "jtag";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+};
index 5a2b98cac6aff23ca668a5f4259c7c456ad9a7f5..9521f2cfd06d74e207eb49f16ee32caf52d19d50 100644 (file)
@@ -954,7 +954,7 @@ endif
 #
 
 ifeq ($(SUBTARGET),mt7621)
 #
 
 ifeq ($(SUBTARGET),mt7621)
-  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626
+  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626 wf-2881
 endif
 
 define Device/mt7621
 endif
 
 define Device/mt7621
@@ -1009,6 +1009,15 @@ define Device/zbt-wg2626
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
 endef
 
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
 endef
 
+define Device/wf-2881
+  DTS := WF-2881
+  BLOCKSIZE := 128KiB
+  PAGESIZE := 2048
+  KERNEL_SIZE := 2097152
+  FILESYSTEMS := squashfs
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+endef
+
 #
 # MT7628 Profiles
 #
 #
 # MT7628 Profiles
 #
index fb05d1e645227eae60c7faab0a92310991c07cdd..13ff9f846716565fa45d73d94c8584b85136e0e2 100644 (file)
@@ -36,6 +36,11 @@ CONFIG_CPU_RMAP=y
 CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
 CONFIG_CPU_SUPPORTS_HIGHMEM=y
 CONFIG_CPU_SUPPORTS_MSA=y
 CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
 CONFIG_CPU_SUPPORTS_HIGHMEM=y
 CONFIG_CPU_SUPPORTS_MSA=y
+CONFIG_CRC16=y
+CONFIG_CRYPTO_DEFLATE=y
+CONFIG_CRYPTO_LZO=y
+CONFIG_CRYPTO_RNG2=y
+CONFIG_CRYPTO_WORKQUEUE=y
 CONFIG_CSRC_R4K=y
 CONFIG_DEBUG_PINCTRL=y
 CONFIG_DMA_NONCOHERENT=y
 CONFIG_CSRC_R4K=y
 CONFIG_DEBUG_PINCTRL=y
 CONFIG_DMA_NONCOHERENT=y
@@ -102,6 +107,8 @@ CONFIG_IRQ_FORCED_THREADING=y
 CONFIG_IRQ_GIC=y
 CONFIG_IRQ_WORK=y
 CONFIG_LIBFDT=y
 CONFIG_IRQ_GIC=y
 CONFIG_IRQ_WORK=y
 CONFIG_LIBFDT=y
+CONFIG_LZO_COMPRESS=y
+CONFIG_LZO_DECOMPRESS=y
 CONFIG_MDIO_BOARDINFO=y
 CONFIG_MIPS=y
 CONFIG_MIPS_CM=y
 CONFIG_MDIO_BOARDINFO=y
 CONFIG_MIPS=y
 CONFIG_MIPS_CM=y
@@ -117,18 +124,26 @@ CONFIG_MIPS_MT_FPAFF=y
 CONFIG_MIPS_MT_SMP=y
 CONFIG_MIPS_PERF_SHARED_TC_COUNTERS=y
 # CONFIG_MIPS_VPE_LOADER is not set
 CONFIG_MIPS_MT_SMP=y
 CONFIG_MIPS_PERF_SHARED_TC_COUNTERS=y
 # CONFIG_MIPS_VPE_LOADER is not set
-# CONFIG_MTK_MTD_NAND is not set
 CONFIG_MODULES_USE_ELF_REL=y
 CONFIG_MT7621_WDT=y
 # CONFIG_MTD_CFI_INTELEXT is not set
 CONFIG_MTD_CMDLINE_PARTS=y
 CONFIG_MTD_M25P80=y
 CONFIG_MODULES_USE_ELF_REL=y
 CONFIG_MT7621_WDT=y
 # CONFIG_MTD_CFI_INTELEXT is not set
 CONFIG_MTD_CMDLINE_PARTS=y
 CONFIG_MTD_M25P80=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_SPLIT_FIRMWARE=y
 CONFIG_MTD_SPLIT_SEAMA_FW=y
 CONFIG_MTD_SPLIT_TRX_FW=y
 CONFIG_MTD_SPLIT_UIMAGE_FW=y
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_SPLIT_FIRMWARE=y
 CONFIG_MTD_SPLIT_SEAMA_FW=y
 CONFIG_MTD_SPLIT_TRX_FW=y
 CONFIG_MTD_SPLIT_UIMAGE_FW=y
+CONFIG_MTD_UBI=y
+CONFIG_MTD_UBI_BEB_LIMIT=20
+CONFIG_MTD_UBI_BLOCK=y
+# CONFIG_MTD_UBI_FASTMAP is not set
+# CONFIG_MTD_UBI_GLUEBI is not set
+CONFIG_MTD_UBI_WL_THRESHOLD=4096
+CONFIG_MTK_MTD_NAND=y
 CONFIG_NEED_DMA_MAP_STATE=y
 CONFIG_NET_FLOW_LIMIT=y
 CONFIG_NET_RALINK=y
 CONFIG_NEED_DMA_MAP_STATE=y
 CONFIG_NET_FLOW_LIMIT=y
 CONFIG_NET_RALINK=y
@@ -209,9 +224,16 @@ CONFIG_SYS_SUPPORTS_SCHED_SMT=y
 CONFIG_SYS_SUPPORTS_SMP=y
 CONFIG_TICK_CPU_ACCOUNTING=y
 CONFIG_TREE_RCU=y
 CONFIG_SYS_SUPPORTS_SMP=y
 CONFIG_TICK_CPU_ACCOUNTING=y
 CONFIG_TREE_RCU=y
+CONFIG_UBIFS_FS=y
+CONFIG_UBIFS_FS_ADVANCED_COMPR=y
+CONFIG_UBIFS_FS_LZO=y
+# CONFIG_UBIFS_FS_XZ is not set
+CONFIG_UBIFS_FS_ZLIB=y
 CONFIG_USB_SUPPORT=y
 CONFIG_USE_OF=y
 CONFIG_WATCHDOG_CORE=y
 CONFIG_WEAK_ORDERING=y
 CONFIG_XPS=y
 CONFIG_USB_SUPPORT=y
 CONFIG_USE_OF=y
 CONFIG_WATCHDOG_CORE=y
 CONFIG_WEAK_ORDERING=y
 CONFIG_XPS=y
+CONFIG_ZLIB_DEFLATE=y
+CONFIG_ZLIB_INFLATE=y
 CONFIG_ZONE_DMA_FLAG=0
 CONFIG_ZONE_DMA_FLAG=0
diff --git a/target/linux/ramips/mt7621/profiles/netis.mk b/target/linux/ramips/mt7621/profiles/netis.mk
new file mode 100644 (file)
index 0000000..39b524f
--- /dev/null
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WF-2881
+       NAME:=NETIS WF-2881
+       PACKAGES:=\
+               kmod-usb-core kmod-usb3 kmod-usb-hid \
+               kmod-ledtrig-usbdev
+endef
+
+define Profile/WF-2881/Description
+       Package set compatible with the NETIS WF-2881 board.
+endef
+
+#-m <min io size> -e <LEB size> -c <Eraseblocks count>
+WF-2881_UBIFS_OPTS:="-m 2048 -e 129024 -c 1024"
+WF-2881_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,WF-2881))