add support for HW553 bcm6358-based boards (#8844)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 15:44:06 +0000 (15:44 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 15:44:06 +0000 (15:44 +0000)
SVN-Revision: 25590

target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-2.6.35/451-board_hw553.patch [new file with mode: 0644]

index b34c7eb5dc94078e8a3a5fd123b14a193043c15d..9d48613c225ad65fac9bca18d9db96091eeec582 100644 (file)
@@ -51,6 +51,15 @@ define Image/Build/CFEFIXUP
                $(6) $(7) $(8) $(9)
 endef
 
+define Image/Build/CFEHW553
+       # Generate the tagged image
+       $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
+               --output $(BIN_DIR)/openwrt-$(5)-$(1)-cfe.bin \
+               --boardid $(2) --chipid $(3) --entry $(LOADADDR) \
+               --load-addr $(LOADADDR) --tag-version 7 \
+               --block-size 0x20000 --image-offset $(4)
+endef
+
 define Image/Build/CFEAGPF
        # Generate the tagged image
        $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
@@ -193,6 +202,9 @@ define Image/Build
 
        # T-Com Speedport W 500V
        $(call Image/Build/CFEFIXUP,$(1),96348GW,6348,SPW500V)
+
+       #HW553
+       $(call Image/Build/CFEHW553,$(1),HW553,6358,0x20000,HW553)
 endef
 
 $(eval $(call BuildImage))
diff --git a/target/linux/brcm63xx/patches-2.6.35/451-board_hw553.patch b/target/linux/brcm63xx/patches-2.6.35/451-board_hw553.patch
new file mode 100644 (file)
index 0000000..6a288c3
--- /dev/null
@@ -0,0 +1,90 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -1730,6 +1730,79 @@ static struct board_info __initdata boar
+ };
+ #endif
++static struct board_info __initdata board_HW553 = {
++      .name                           = "HW553",
++      .expected_cpu_id                = 0x6358,
++
++      .has_enet0                      = 1,
++      .has_enet1                      = 1,
++      .has_pci                        = 1,
++
++      .enet0 = {
++              .has_phy                = 1,
++              .use_internal_phy       = 1,
++      },
++
++      .enet1 = {
++              .force_speed_100        = 1,
++              .force_duplex_full      = 1,
++      },
++
++      .has_ohci0 = 1,
++      .has_ehci0 = 1,
++
++      .leds = {
++              /*Each led on HW553 is bi-color (except wifi) */                
++              {
++                      .name           = "lan:red",
++                      .gpio           = 34,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "lan:blue",
++                      .gpio           = 35,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "adsl:red",
++                      .gpio           = 22,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "adsl:blue",
++                      .gpio           = 23,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "power:red",
++                      .gpio           = 5,
++                      .active_low     = 1,
++                      .default_trigger = "default-on",
++              },
++
++              {
++                      .name           = "power:blue",
++                      .gpio           = 4,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "wifi:red",
++                      .gpio           = 25,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "internetkey:red",
++                      .gpio           = 12,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "internetkey:blue",
++                      .gpio           = 13,
++                      .active_low     = 1,
++              },
++      },
++};
++
+ /*
+  * all boards
+  */
+@@ -1771,6 +1844,7 @@ static const struct board_info __initdat
+       &board_nb4_ser_r2,
+       &board_nb4_fxc_r1,
+       &board_nb4_fxc_r2,
++      &board_HW553,
+ #endif
+ };