ramips: rt305x: support for wr512-3gn-like routers
authorGabor Juhos <juhosg@openwrt.org>
Fri, 19 Aug 2011 15:55:10 +0000 (15:55 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 19 Aug 2011 15:55:10 +0000 (15:55 +0000)
Signed-off-by: Andrew Andrianov <necromant@necromant.ath.cx>
SVN-Revision: 28052

target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wr512-3gn.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-2.6.39

index a54edbabe7ad9aa0e54690c8dbd56c26bbc69d1a..0f50c9bc1b5e772e3e3a210fb079f6e321a6366e 100644 (file)
@@ -54,7 +54,8 @@ case "$FIRMWARE" in
        rt-n15 | \
        v22rw-2x2 | \
        wcr150gn | \
-       whr-g300n)
+       whr-g300n | \
+       wr512-3gn)
                rt2x00_eeprom_extract "factory" 0 272
                ;;
 
index 616e966976d22a83486a1a6f24236d63d96f1a2e..1ab8f7913a2c395171613155999f5b58e9221135 100755 (executable)
@@ -58,6 +58,9 @@ ramips_board_name() {
        *"WZR-AGL300NH")
                name="wzr-agl300nh"
                ;;
+       *"SH-WR512NU/WS-WR512N1-like 3GN router")
+               name="wr512-3gn"
+               ;;
        *)
                name="generic"
                ;;
index baaff71faf98c037b3dff2cf5933a32c32317416..7997d17d9e1acb8122422fdbe30fe898a5e3d3ca 100644 (file)
@@ -34,4 +34,5 @@ enum ramips_mach_type {
        RAMIPS_MACH_FONERA20N,          /* La Fonera 2.0N */
        RAMIPS_MACH_HW550_3G,           /* Aztech HW550-3G */
        RAMIPS_MACH_MOFI3500_3GN,       /* MoFi Network MOFI3500-3GN */
+       RAMIPS_MACH_WR512_3GN,          /* SH-WR512NU/WS-WR512N1-like 3GN*/
 };
index 36b1515b3c464ae6e135adabeece7a4b3ab853fa..ad1122b0c6caee07561584d5471f5e7dd4aafb89 100644 (file)
@@ -49,6 +49,11 @@ config RT305X_MACH_MOFI3500_3GN
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_WR512_3GN
+       bool "SH-WR512NU/WS-WR512N1-like 3GN router"
+       default n
+
+
 config RT305X_MACH_NW718
        bool "Netcore NW718"
        default y
index 75f4782c23a703ba563a30a23e79450e34f8abab..0d2e8b201a23da0e5bf6c566eb2b6af6b1cb6ba9 100644 (file)
@@ -17,9 +17,11 @@ obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
 obj-$(CONFIG_RT305X_MACH_HW550_3G)     += mach-hw550-3g.o
 obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
+obj-$(CONFIG_RT305X_MACH_WR512_3GN)    += mach-wr512-3gn.o
 obj-$(CONFIG_RT305X_MACH_NW718)                += mach-nw718.o
 obj-$(CONFIG_RT305X_MACH_PWH2004)      += mach-pwh2004.o
 obj-$(CONFIG_RT305X_MACH_RT_G32_REVB)  += mach-rt-g32-revb.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
 obj-$(CONFIG_RT305X_MACH_WCR150GN)     += mach-wcr150gn.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
+
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wr512-3gn.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wr512-3gn.c
new file mode 100644 (file)
index 0000000..52b3cde
--- /dev/null
@@ -0,0 +1,153 @@
+/*
+ *  Unbranded router from DX board support
+ *  Also known as *WR512*-3GN by local vendors
+ *  e.g. WS-WR512N1, Sin Hon SH-WR512NU, and etc
+ *  (http://www.dealextreme.com/p/portable-wireless-n-3g-router-cdma2000-evdo-td-scdma-hspa-wcdma-45639)
+ *  This router is also known to be rebranded and sold by a number of local
+ *  vendors in several countries.
+ *
+ *  Copyright (C) 2011 Andrew Andrianov <necromant@necromant.ath.cx>
+ *  Based on MOFI3500-3N code by
+ *  Copyright (C) 2011 Layne Edwards <ledwards76@gmail.com>
+ *
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+
+#define WR512_3GN_GPIO_LED_3G          9
+#define WR512_3GN_GPIO_LED_GATEWAY     11
+#define WR512_3GN_GPIO_LED_AP          12
+#define WR512_3GN_GPIO_LED_STATION     13
+#define WR512_3GN_GPIO_LED_WPS         14
+
+#define WR512_3GN_GPIO_BUTTON_RESET    10
+#define WR512_3GN_GPIO_BUTTON_CONNECT  7
+#define WR512_3GN_GPIO_BUTTON_WPS      0
+#define WR512_3GN_GPIO_BUTTON_WPS2     8
+
+#define WR512_3GN_BUTTONS_POLL_INTERVAL        20
+
+#ifdef CONFIG_MTD_PARTITIONS
+
+static struct mtd_partition wr512_3gn_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "devdata",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "devconf",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x0d0000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x120000,
+               .size   = 0x2e0000,
+       }, {
+               .name   = "firmware",
+               .offset = 0x050000,
+               .size   = 0x3b0000,
+       }
+};
+
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data wr512_3gn_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(wr512_3gn_partitions),
+       .parts          = wr512_3gn_partitions,
+#endif
+};
+
+static struct gpio_led wr512_3gn_leds_gpio[] __initdata = {
+       {
+               .name           = "wr512:green:3g",
+               .gpio           = WR512_3GN_GPIO_LED_3G,
+               .active_low     = 1,
+       }, {
+               .name           = "wr512:green:gateway",
+               .gpio           = WR512_3GN_GPIO_LED_GATEWAY,
+               .active_low     = 1,
+       }, {
+               .name           = "wr512:green:ap",
+               .gpio           = WR512_3GN_GPIO_LED_AP,
+               .active_low     = 1,
+       }, {
+               .name           = "wr512:green:wps",
+               .gpio           = WR512_3GN_GPIO_LED_WPS,
+               .active_low     = 1,
+       }, {
+               .name           = "wr512:green:station",
+               .gpio           = WR512_3GN_GPIO_LED_STATION,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_button wr512_3gn_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset_wps",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = WR512_3GN_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "mode",
+               .type           = EV_KEY,
+               .code           = KEY_M,
+               .threshold      = 3,
+               .gpio           = WR512_3GN_GPIO_BUTTON_CONNECT,
+               .active_low     = 1,
+       }
+};
+
+#define WR512_3GN_GPIO_MODE \
+       ((RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT) | \
+        RT305X_GPIO_MODE_MDIO)
+
+static void __init wr512_3gn_init(void)
+{
+       rt305x_gpio_init(WR512_3GN_GPIO_MODE);
+
+       rt305x_register_flash(0, &wr512_3gn_flash_data);
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(wr512_3gn_leds_gpio),
+                                 wr512_3gn_leds_gpio);
+       ramips_register_gpio_buttons(-1, WR512_3GN_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(wr512_3gn_gpio_buttons),
+                                    wr512_3gn_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_WR512_3GN, "WR512-3GN", "WR512-3GN-like router",
+             wr512_3gn_init);
index bbbf0e612b536fd8eebc2a22557e863a1fbbb436..46108a80541796d33f073376a96b97c391fe6b6a 100644 (file)
@@ -146,6 +146,16 @@ define Image/Build/Template/RTG32B1
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_rtg32b1,$(mtd_rtg32b1_kernel_part_size),$(mtd_rtg32b1_rootfs_part_size))
 endef
 
+mtdlayout_wr5123gn=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
+mtdlayout_wr5123gn8m=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
+define Image/Build/Template/WR5123GN
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_wr5123gn,851968,3014656)
+endef
+
+define Image/Build/Template/WR5123GN8M
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_wr5123gn8m,851968,3014656)
+endef
+
 define Image/Build/Profile/RTG32B1
        $(call Image/Build/Template/RTG32B1,$(1),rt-g32-b1,RT-G32-B1)
 endef
@@ -210,7 +220,6 @@ define Image/Build/Profile/ARGUS_ATP52B
        $(call Image/Build/Template/ARGUS_ATP52B,$(1),argus_atp52b,ARGUS_ATP52B)
 endef
 
-
 mtdlayout_f5d8235=mtdparts=physmap-flash.0:320k(u-boot)ro,1536k(kernel),6208k(rootfs),64k(nvram),64k(factory),7744k@0x50000(firmware)
 mtd_f5d8235_kernel_part_size=1572864
 mtd_f5d8235_rootfs_part_size=6356992
@@ -222,6 +231,10 @@ define Image/Build/Profile/F5D8235V2
        $(call Image/Build/Template/F5D8235V2,$(1),f5d8235v2,F5D8235_V2)
 endef
 
+define Image/Build/Profile/WR5123GN
+$(call Image/Build/Template/WR5123GN,$(1),wr512-3gn,WR512-3GN)
+endef
+
 
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
@@ -237,6 +250,8 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/F5D8235V2,$(1))
        $(call Image/Build/Profile/HW5503G,$(1))
        $(call Image/Build/Profile/MOFI35003GN,$(1))
+       $(call Image/Build/Profile/WR5123GN,$(1))
+       $(call Image/Build/Profile/WR5123GN8M,$(1))
 endef
 endif
 
index e15fa072afc0e49b9b201eeee51be2dda8e0af12..3276d14924c8c7f38649b88e2fa1c8cc7e68a2ef 100644 (file)
@@ -103,6 +103,7 @@ CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_WCR150GN=y
 CONFIG_RT305X_MACH_WHR_G300N=y
+CONFIG_RT305X_MACH_WR512_3GN=y
 # CONFIG_SCSI_DMA is not set
 CONFIG_SERIAL_8250_NR_UARTS=4
 CONFIG_SERIAL_8250_RT288X=y