uci: use latest git, fixes reorder operation and incorperates nested delete patch
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 19 Jan 2011 20:48:07 +0000 (20:48 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 19 Jan 2011 20:48:07 +0000 (20:48 +0000)
SVN-Revision: 25048

package/uci/Makefile
package/uci/patches/130-lua_fix_nested_foreach_delete.patch [deleted file]

index c9fc6a63c4c8e503053e5249b3bb184f3ee80e03..78b3fa8e3a0ba7d081d0a693fd4c54d65c47d479 100644 (file)
@@ -7,13 +7,13 @@
 
 include $(TOPDIR)/rules.mk
 
-UCI_VERSION=2010-09-28
-UCI_RELEASE=2
+UCI_VERSION=2011-01-19
+UCI_RELEASE=1
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
-PKG_RELEASE:=2
-PKG_REV:=3fa65a20ae0fc77b951515bc5de7a0041adc9be1
+PKG_RELEASE:=1
+PKG_REV:=a5eb996e0f04d911ff61479508bbc3e17b16ff0c
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://nbd.name/uci.git
diff --git a/package/uci/patches/130-lua_fix_nested_foreach_delete.patch b/package/uci/patches/130-lua_fix_nested_foreach_delete.patch
deleted file mode 100644 (file)
index 70c23ad..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/lua/uci.c
-+++ b/lua/uci.c
-@@ -266,7 +266,7 @@ uci_lua_foreach(lua_State *L)
- {
-       struct uci_context *ctx;
-       struct uci_package *p;
--      struct uci_element *e;
-+      struct uci_element *e, *tmp;
-       const char *package, *type;
-       bool ret = false;
-       int offset = 0;
-@@ -287,7 +287,7 @@ uci_lua_foreach(lua_State *L)
-       if (!p)
-               goto done;
--      uci_foreach_element(&p->sections, e) {
-+      uci_foreach_element_safe(&p->sections, tmp, e) {
-               struct uci_section *s = uci_to_section(e);
-               i++;