build: add new option to add disabled feeds commented out to opkg.conf
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 6 Aug 2014 09:12:37 +0000 (09:12 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 6 Aug 2014 09:12:37 +0000 (09:12 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 42004

package/base-files/image-config.in
package/system/opkg/Makefile

index d745369a2c71e6ddacea84c1d36de0d7860f24fa..3029648d85bb4aa39eb240bd0f7f159b5cbe66d5 100644 (file)
@@ -216,6 +216,13 @@ menuconfig PER_FEED_REPO
                If set, a separate repository is generated within bin/*/packages/
                for the core packages and each enabled feed.
 
+       config PER_FEED_REPO_ADD_DISABLED
+               bool "Add installed but disabled feeds to opkg.conf"
+               default y
+               depends on PER_FEED_REPO
+               help
+                 Add installed but disabled feeds as commented out source lines to opkg.conf.
+
 source "tmp/.config-feeds.in"
 
 
index 5dfabc2ca2838f630ac6bbd0a2c7d29db94bb842..8a63fb4352c648cef58c03ee6f02950a7d2030d5 100644 (file)
@@ -111,6 +111,11 @@ define Package/opkg/Default/install
        for d in base $(FEEDS_ENABLED); do \
                echo "src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
        done
+    ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
+       for d in $(FEEDS_DISABLED); do \
+               echo "# src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
+       done
+    endif
   endif
        $(VERSION_SED) $(1)/etc/opkg.conf
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg