ar71xx/image: relink loader.elf image to LOADADDR
authorGabor Juhos <juhosg@openwrt.org>
Tue, 20 Nov 2012 12:17:41 +0000 (12:17 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 20 Nov 2012 12:17:41 +0000 (12:17 +0000)
This allows to load the resulting image directly
from RouterBOOT.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34271

target/linux/ar71xx/image/lzma-loader/src/Makefile
target/linux/ar71xx/image/lzma-loader/src/loader2.lds [new file with mode: 0644]

index 3e6839c7c3899d0283a3879af6e998abe99970d0..8038b2fba9375a42db4be8af98407845b6c80e37 100644 (file)
@@ -68,7 +68,7 @@ ifneq ($(BOARD_DEF),)
 CFLAGS         += -DCONFIG_BOARD_$(BOARD_DEF)
 endif
 
-all: loader.bin
+all: loader.elf
 
 # Don't build dependencies, this may die if $(CC) isn't gcc
 dep:
@@ -84,16 +84,22 @@ install:
 data.o: $(LOADER_DATA)
        $(LD) -r -b binary --oformat $(O_FORMAT) -T lzma-data.lds -o $@ $<
 
-loader.bin: loader.elf
+loader: $(OBJECTS)
+       $(LD) $(LDFLAGS) -o $@ $(OBJECTS)
+
+loader.bin: loader
        $(OBJCOPY) $(BIN_FLAGS) $< $@
 
-loader.elf: $(OBJECTS)
-       $(LD) $(LDFLAGS) -o $@ $(OBJECTS)
+loader2.o: loader.bin
+       $(LD) -r -b binary --oformat $(O_FORMAT) -o $@ $<
+
+loader.elf: loader2.o
+       $(LD) -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
 
 mrproper: clean
 
 clean:
-       rm -f *.elf *.bin *.o
+       rm -f loader *.elf *.bin *.o
 
 
 
diff --git a/target/linux/ar71xx/image/lzma-loader/src/loader2.lds b/target/linux/ar71xx/image/lzma-loader/src/loader2.lds
new file mode 100644 (file)
index 0000000..db0bb46
--- /dev/null
@@ -0,0 +1,10 @@
+OUTPUT_ARCH(mips)
+SECTIONS {
+       .text : {
+               startup = .;
+               *(.text)
+               *(.text.*)
+               *(.data)
+               *(.data.*)
+       }
+}