sunxi: move sunxi-sid (security ID) off to module
authorZoltan Herpai <wigyori@uid0.hu>
Sat, 4 Jan 2014 13:46:43 +0000 (13:46 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Sat, 4 Jan 2014 13:46:43 +0000 (13:46 +0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
SVN-Revision: 39196

target/linux/sunxi/Makefile
target/linux/sunxi/config-3.12
target/linux/sunxi/modules.mk

index 0ababde87b3e096776919ed81e3819d650d9a527..c340d86b8dc1f6101b6c3c06d5d2673613e92f3a 100644 (file)
@@ -17,7 +17,7 @@ MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
 LINUX_VERSION:=3.12.5
 KERNELNAME:="zImage dtbs"
-DEFAULT_PACKAGES += uboot-envtools uboot-sunxi
+DEFAULT_PACKAGES += uboot-envtools uboot-sunxi kmod-eeprom-sunxi
 
 # A10: Cortex-A8
 # A13: Cortex-A8
index a49d8cab2790c9d0649478e80e1e054c12ab43d8..3b0d0b327b3383316ebb6e2d413e1377be1ade05 100644 (file)
@@ -132,7 +132,7 @@ CONFIG_DTC=y
 CONFIG_DUMMY_CONSOLE=y
 # CONFIG_DW_DMAC_CORE is not set
 CONFIG_DYNAMIC_DEBUG=y
-CONFIG_EEPROM_SUNXI_SID=y
+# CONFIG_EEPROM_SUNXI_SID is not set
 CONFIG_ELF_CORE=y
 # CONFIG_EMBEDDED is not set
 CONFIG_ENABLE_MUST_CHECK=y
index 8677a6949457e0cc9cd3be296991e1ad0059da23..5fffbc7a8b47a57ce357b836d2c42acbd36b1205 100644 (file)
@@ -22,3 +22,19 @@ endef
 
 $(eval $(call KernelPackage,rtc-sunxi))
 
+define KernelPackage/eeprom-sunxi
+    SUBMENU:=$(OTHER_MENU)
+    TITLE:=AllWinner Security ID fuse support
+    DEPENDS:=@TARGET_sunxi
+    KCONFIG:= \
+       CONFIG_EEPROM_SUNXI_SID
+    FILES:=$(LINUX_DIR)/drivers/misc/eeprom/sunxi_sid.ko
+    AUTOLOAD:=$(call AutoLoad,50,sunxi_sid)
+endef
+
+define KernelPackage/eeprom-sunxi/description
+ Support for the AllWinner Security ID fuse support
+endef
+
+$(eval $(call KernelPackage,eeprom-sunxi))
+