tools/bison: update to 3.7.4
authorHannu Nyman <hannu.nyman@iki.fi>
Sat, 21 Nov 2020 11:30:34 +0000 (13:30 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 21 Nov 2020 17:49:08 +0000 (18:49 +0100)
Update bison to 3.7.4

Release notes:
http://git.savannah.gnu.org/cgit/bison.git/tree/NEWS?id=7a11a9308cb

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
tools/bison/Makefile
tools/bison/patches/100-fix-gets-removal.patch

index fde812f3344331f79ade26345f01d7bace1bcc93..8f3043fcb8dd8c5a9c220747a888952cfe747613 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
-PKG_VERSION:=3.7.1
+PKG_VERSION:=3.7.4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_HASH:=55c215521a13982a9bee68cd42eed51a65713f96c530a739a57de4438ac1bb69
+PKG_HASH:=a3b5813f48a11e540ef26f46e4d288c0c25c7907d9879ae50e430ec49f63c010
 
 HOST_BUILD_PARALLEL:=1
 
index f97e8a398597f772e1cb9a41ab6dd48ee12b2776..534713f18097a57c9d4dce78d0b5ef49fa60a162 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/stdio.in.h
 +++ b/lib/stdio.in.h
-@@ -816,14 +816,6 @@ _GL_WARN_ON_USE (getline, "getline is un
+@@ -835,14 +835,6 @@ _GL_WARN_ON_USE (getline, "getline is un
  # endif
  #endif
  
@@ -12,6 +12,6 @@
 -_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
 -#endif
 -
- #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
- struct obstack;
- /* Grow an obstack with formatted output.  Return the number of
+ #if defined _WIN32 && !defined __CYGWIN__
+ # undef getw
+ # define getw _getw