build: IS_TTY is now set according to GNU Make's MAKE_TERMOUT
authorR. Diez <rdiezmail-openwrt@yahoo.com>
Wed, 10 Jun 2020 09:33:26 +0000 (11:33 +0200)
committerPaul Spooren <mail@aparcar.org>
Tue, 16 Feb 2021 02:36:13 +0000 (16:36 -1000)
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
Fixes: FS#2086
The logic for IS_TTY was broken, because it was testing stdin
instead of stdout.
MAKE_TERMOUT was introduced in GNU Make version 4.1 (05 Oct 2014),
so it should be available everywhere nowadays.

Signed-off-by: R. Diez <rdiezmail-openwrt@yahoo.com>
include/toplevel.mk

index 744695b19c9fc8f899f197392ebe2abb11ae6a76..48ea44aa2480ad2d80ca1dc2d45cf8a8193a109d 100644 (file)
@@ -4,7 +4,7 @@
 
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
-export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+export IS_TTY=$(if $(MAKE_TERMOUT),1,0)
 
 include $(TOPDIR)/include/verbose.mk