apm821xx: remove unnecessary kernel padding
authorRussell Senior <russell@personaltelco.net>
Sat, 21 Sep 2019 08:58:07 +0000 (01:58 -0700)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 21 Sep 2019 21:41:31 +0000 (23:41 +0200)
The allocation of LEBs to ubi volumes is handled by the sysupgrade script:

  package/base-files/files/lib/upgrade/nand.sh

and the ubimkvol and or ubirsvol command. Therefore, padding of the
kernel blob is not needed at all, so use cat instead of dd. The
BLOCKSIZE variable was only used in the dd command.  In any case, 63k
made no sense for the way BLOCKSIZE was being used.

63k (64512) does make sense for DTB_SIZE because of the offsets expected
by u-boot given extant u-boot-env variables.

Tested on Meraki MR24.

Signed-off-by: Russell Senior <russell@personaltelco.net>
target/linux/apm821xx/image/Makefile

index 8203de39c5672d0b63225a452d0b8d42757e8c93..108f63cb7a942aaa314c3b0e01b3ff417d33eb97 100644 (file)
@@ -58,7 +58,7 @@ define Build/MerakiAdd-dtb
        $(call Image/BuildDTB,../dts/$(DEVICE_DTS).dts,$@.dtb)
        ( \
                dd if=$@.dtb bs=$(DTB_SIZE) conv=sync; \
-               dd if=$@ bs=$(BLOCKSIZE) conv=sync; \
+               cat $@ ; \
        ) > $@.new
        @mv $@.new $@
 endef
@@ -127,7 +127,6 @@ define Device/meraki_mr24
   DEVICE_PACKAGES := kmod-spi-gpio -swconfig
   BOARD_NAME := mr24
   DEVICE_DTS := meraki-mr24
-  BLOCKSIZE := 63k
   IMAGES := sysupgrade.bin
   DTB_SIZE := 64512
   IMAGE_SIZE := 8191k