fix .pkginfo line to allow the use of $(SOURCE)
authorMike Baker <mbm@openwrt.org>
Fri, 19 May 2006 23:02:14 +0000 (23:02 +0000)
committerMike Baker <mbm@openwrt.org>
Fri, 19 May 2006 23:02:14 +0000 (23:02 +0000)
SVN-Revision: 3802

openwrt/Makefile
openwrt/package/busybox/Makefile

index 9b9d1c955e13db4dcdd30951fb87b042a38b2df0..9b341f1241a8246060e28cc78a0a3fd27a0447e0 100644 (file)
@@ -41,11 +41,11 @@ export OPENWRTVERSION
 all:
 
 .pkginfo: FORCE
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
        @echo Collecting package info...
-       @-for makefile in package/*/Makefile; do \
-               echo Source-Makefile: $$makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -f $$makefile 2>&- || true; \
+       @-for dir in package/*/; do \
+               echo Source-Makefile: $${dir}Makefile; \
+               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
 endif
 
index ff23ee7dd81864cb7d62fc0493673a94528320cc..cc36301f52ad5e00a78ccea831b291737a59d9be 100644 (file)
@@ -23,10 +23,11 @@ TITLE:=Core utilities for embedded Linux
 DESCRIPTION:=The Swiss Army Knife of embedded Linux. \\\
 It slices, it dices, it makes Julian Fries.
 URL:=http://busybox.net/
-CONFIG:=menu "Configuration" \\\
-       depends on PACKAGE_busybox \\\
-source "package/busybox/config/Config.in" \\\
-endmenu
+CONFIG:=\\\
+       menu "Configuration" \\\
+               depends on PACKAGE_busybox \\\
+               source "$(SOURCE)/config/Config.in" \\\
+       endmenu
 endef
 
 define Build/Configure