Remove remaining etrax references
authorJohn Crispin <john@openwrt.org>
Wed, 2 Jan 2013 11:28:11 +0000 (11:28 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 2 Jan 2013 11:28:11 +0000 (11:28 +0000)
SVN-Revision: 34968

package/kernel/modules/block.mk
package/kernel/modules/i2c.mk
package/kernel/modules/usb.mk
package/kernel/modules/video.mk
package/network/services/hostapd/Makefile
package/network/utils/iw/Makefile

index ba2443957aba8be2405ae42cef4fe2151fedf287..373230b9a6c09d539f2c0367f16730ead1261da6 100644 (file)
@@ -25,7 +25,7 @@ $(eval $(call KernelPackage,aoe))
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core @!TARGET_etrax
+  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.ko
   AUTOLOAD:=$(call AutoLoad,21,libata,1)
index 49d8250777e9bd39c4515841de7e0db730993deb..0a4982010c89bd7101c791c8c43383e8f96d7edf 100644 (file)
@@ -27,7 +27,6 @@ I2C_CORE_MODULES:= \
 define KernelPackage/i2c-core
   $(call i2c_defaults,$(I2C_CORE_MODULES),51)
   TITLE:=I2C support
-  DEPENDS:=@!TARGET_etrax
 endef
 
 define KernelPackage/i2c-core/description
index 459920326a2b208e45df509810f3f1a4b6083ffd..5947e88174537d8a47b20f704ba8339240a2e726 100644 (file)
@@ -32,7 +32,7 @@ $(eval $(call KernelPackage,usb-core))
 
 define AddDepends/usb
   SUBMENU:=$(USB_MENU)
-  DEPENDS+=+!TARGET_etrax:kmod-usb-core $(1)
+  DEPENDS+=+kmod-usb-core $(1)
 endef
 
 
index ae6012aeb2af09c496a3315d253034f948a9c101..e652e8a4f0e89b1b30a8665eb26d1ddb2d7ec897 100644 (file)
@@ -82,7 +82,7 @@ $(eval $(call KernelPackage,fb-cfb-imgblt))
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
   TITLE=Video4Linux support
-  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT +!TARGET_etrax:kmod-i2c-core
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
   KCONFIG:= \
        CONFIG_MEDIA_SUPPORT=m \
        CONFIG_MEDIA_CAMERA_SUPPORT=y \
index 3f8474c6274a72a4ef85d1950aeaba95928dc624..44b6684416c3e08c74a6c2f54b4572df7d2afd1e 100644 (file)
@@ -86,7 +86,7 @@ ifneq ($(LOCAL_TYPE),hostapd)
        CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
 endif
 
-DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!(TARGET_avr32||TARGET_etrax)||BROKEN)
+DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!TARGET_avr32||BROKEN)
 
 define Package/hostapd/Default
   SECTION:=net
index b63a61ceccd621b6919fe60ac7a1135de780014f..91167d8b3b1b0cf1cc0c1874a0f2f16f65a7c224 100644 (file)
@@ -24,7 +24,7 @@ define Package/iw
   CATEGORY:=Network
   TITLE:=cfg80211 interface configuration utility
   URL:=http://wireless.kernel.org/en/users/Documentation/iw
-  DEPENDS:= +libnl-tiny @(!(TARGET_avr32||TARGET_etrax)||BROKEN)
+  DEPENDS:= +libnl-tiny @(!TARGET_avr32||BROKEN)
 endef
 
 define Build/Configure