.pkginfo cleanup #2
authorMike Baker <mbm@openwrt.org>
Fri, 23 Jun 2006 00:49:42 +0000 (00:49 +0000)
committerMike Baker <mbm@openwrt.org>
Fri, 23 Jun 2006 00:49:42 +0000 (00:49 +0000)
SVN-Revision: 4053

openwrt/include/kernel-build.mk
openwrt/include/kernel.mk
openwrt/package/base-files/Makefile

index fc62127ca2641544d1eb7bba1f0aae55a773d7fd..d3c47281faa33ad3f74bd7078b78e54d11cf079e 100644 (file)
@@ -1,4 +1,4 @@
-include $(INCLUDE_DIR)/modules-$(KERNEL).mk
+-include $(INCLUDE_DIR)/modules-$(KERNEL).mk
 
 LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
 LINUX_SITE=http://www.us.kernel.org/pub/linux/kernel/v$(KERNEL) \
index 8492998020c000d926db8be4fc3087ac47d48d51..c110f687a341daa3959b0e3a52211eecf0936fb4 100644 (file)
@@ -1,9 +1,9 @@
-KERNEL:=kernel
-BOARD:=board
-LINUX_VERSION:=kernel
-
-ifneq ($(DUMP),1)
-include $(TOPDIR)/.kernel.mk
+ifeq ($(DUMP),1)
+  KERNEL:=<KERNEL>
+  BOARD:=<BOARD>
+  LINUX_VERSION:=<LINUX_VERSION>
+else
+-include $(TOPDIR)/.kernel.mk
 
 ifneq (,$(findstring 2.4.,$(LINUX_VERSION)))
 KERNEL:=2.4
index 7db0d0503cf840088f6682c52ff8624eed06da69..f81c681c2649e2c86dee0601a559bed880a21045 100644 (file)
@@ -18,6 +18,9 @@ ifneq ($(DUMP),1)
 TARGET:=-$(BOARD)-$(KERNEL)
 UCLIBC_VERSION:=${shell cat $(STAGING_DIR)/uclibc_version}
 LIBGCC_VERSION:=${shell cat $(STAGING_DIR)/gcc_version}
+else
+UCLIBC_VERSION:=<UCLIBC_VERSION>
+LIBGCC_VERSION:=<LIBGCC_VERSION>
 endif
 
 CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)