sunxi: add support for Orange Pi Plus (H3)
authorZoltan Herpai <wigyori@uid0.hu>
Tue, 2 Feb 2016 22:25:05 +0000 (22:25 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Tue, 2 Feb 2016 22:25:05 +0000 (22:25 +0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
SVN-Revision: 48618

target/linux/sunxi/Makefile
target/linux/sunxi/image/Makefile
target/linux/sunxi/profiles/orangepi_plus.mk [new file with mode: 0644]

index fe18fc3a5f3bab2347ac36233ccaf4364b91c43e..27bb2fe7487d614aaff9a788d622e9d8b9f0a8cf 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013-2014 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 5a5c98a7c03625a79efcd80bbc10f9b4cdcbbd71..bda690e39cde198b9a9219bbe25b1c52bc38db39 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -107,6 +107,10 @@ define Image/Build/Profile/Linksprite_pcDuino3
        $(call Image/Build/SDCard,$(1),sun7i-a20-pcduino3)
 endef
 
+define Image/Build/Profile/orangepi_plus
+       $(call Image/Build/SDCard,$(1),sun8i-h3-orangepi-plus)
+endef
+
 define Image/Build
        $(call Image/Build/$(1),$(1))
        $(call Image/Build/Profile/$(PROFILE),$(1))
diff --git a/target/linux/sunxi/profiles/orangepi_plus.mk b/target/linux/sunxi/profiles/orangepi_plus.mk
new file mode 100644 (file)
index 0000000..c83f508
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/orangepi_plus
+       NAME:=orangepi_plus
+       PACKAGES:=\
+               kmod-rtc-sunxi uboot-sunxi-xunlong_orangepi_plus
+endef
+
+define Profile/orangepi_plus/Description
+       Package set optimized for the OrangePi Plus (H3)
+endef
+
+$(eval $(call Profile,orangepi_plus))