mtd: mark as nonshared to fix FS#484
authorMirko Parthey <mirko.parthey@web.de>
Thu, 31 May 2018 13:24:31 +0000 (15:24 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 5 Jun 2018 16:50:40 +0000 (18:50 +0200)
Upstream commit: 46d7ced9d1e104693a9f995bfe8a6e28ac82b592

The mtd tool is built with different configurations depending on the
target. For example, brcm47xx adds the fixtrx subcommand, without which
an image fails when booting the second time.

Mark the mtd package as nonshared to really fix FS#484.

Signed-off-by: Mirko Parthey <mirko.parthey@web.de>
package/system/mtd/Makefile

index 01277d9f46bbaca271b1603811b9d0b92abfdcdb..9ae03a77a9faf83e3d7b9055cb3efa7cdccf7649 100644 (file)
@@ -17,6 +17,8 @@ STAMP_PREPARED := $(STAMP_PREPARED)_$(call confvar,CONFIG_MTD_REDBOOT_PARTS)
 PKG_LICENSE:=GPL-2.0+
 PKG_LICENSE_FILES:=
 
+PKG_FLAGS:=nonshared
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mtd