ath79: image: use 'kmod-usb-chipidea2' for AR933x devices
authorPiotr Dymacz <pepe2k@gmail.com>
Mon, 21 Feb 2022 21:15:45 +0000 (22:15 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Mon, 21 Feb 2022 21:22:30 +0000 (22:22 +0100)
AR933x based devices should include 'kmod-usb-chipidea2' for USB
support. Fixes: #9243.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ath79/image/generic.mk
target/linux/ath79/image/tiny.mk

index 8988ac7a5e93c77fa1bb0cc5cee00e0a5cd00849..b01eff7d0b0b2b1e803d9f4509e67f9ea2626b53 100644 (file)
@@ -1204,7 +1204,7 @@ define Device/glinet_6408
   SOC := ar9331
   DEVICE_VENDOR := GL.iNet
   DEVICE_MODEL := 6408
-  DEVICE_PACKAGES := kmod-usb2
+  DEVICE_PACKAGES := kmod-usb-chipidea2
   IMAGE_SIZE := 8000k
   TPLINK_HWID := 0x08000001
   IMAGES := sysupgrade.bin
@@ -1217,7 +1217,7 @@ define Device/glinet_6416
   SOC := ar9331
   DEVICE_VENDOR := GL.iNet
   DEVICE_MODEL := 6416
-  DEVICE_PACKAGES := kmod-usb2
+  DEVICE_PACKAGES := kmod-usb-chipidea2
   IMAGE_SIZE := 16192k
   TPLINK_HWID := 0x08000001
   IMAGES := sysupgrade.bin
index f4a03e284010787a259cee2a9233422d8a0857e9..0f355ef9142ed25b21e1aa4082460b07f43eb044 100644 (file)
@@ -73,7 +73,7 @@ define Device/pqi_air-pen
   SOC := ar9330
   DEVICE_VENDOR := PQI
   DEVICE_MODEL := Air-Pen
-  DEVICE_PACKAGES := kmod-usb2
+  DEVICE_PACKAGES := kmod-usb-chipidea2
   IMAGE_SIZE := 7680k
   SUPPORTED_DEVICES += pqi-air-pen
 endef