kernel: add kmod-iio-htu21
authorTorbjörn Jansson <torbjorn.jansson@mbox200.swipnet.se>
Mon, 30 Jul 2018 13:59:20 +0000 (15:59 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 17:34:43 +0000 (19:34 +0200)
This adds support for the htu21 humidity and temperature sensor.

To get it to work you have to do something like this:
echo "htu21 0x40" >/sys/class/i2c-dev/i2c-1/device/new_device
for example by adding it to rc.local

Compile tested on brcm2708 and I have used an earlier version of this
patch for more than a year.

Signed-off-by: Torbjörn Jansson <torbjorn.jansson@mbox200.swipnet.se>
package/kernel/linux/modules/iio.mk

index c35ccca1bb722fc94ffb5d9adad83fef766e8936..a1410170db1b4b5d37fdb4a5c18adf26f781738b 100644 (file)
@@ -133,3 +133,25 @@ define KernelPackage/iio-bmp280-spi/description
 endef
 
 $(eval $(call KernelPackage,iio-bmp280-spi))
+
+define KernelPackage/iio-htu21
+  SUBMENU:=$(IIO_MENU)
+  DEPENDS:=+kmod-i2c-core +kmod-iio-core
+  TITLE:=HTU21 humidity & temperature sensor
+  KCONFIG:= \
+       CONFIG_HTU21 \
+       CONFIG_IIO_MS_SENSORS_I2C
+  FILES:= \
+       $(LINUX_DIR)/drivers/iio/humidity/htu21.ko \
+       $(LINUX_DIR)/drivers/iio/common/ms_sensors/ms_sensors_i2c.ko
+  AUTOLOAD:=$(call AutoLoad,56,htu21)
+endef
+
+define KernelPackage/iio-htu21/description
+ support for the Measurement Specialties HTU21 humidity and
+ temperature sensor.
+ This driver is also used for MS8607 temperature, pressure & humidity
+ sensor
+endef
+
+$(eval $(call KernelPackage,iio-htu21))