kernel: Remove AutoLoad for legacy usb gadget modules
authorChuanhong Guo <gch981213@gmail.com>
Fri, 20 Apr 2018 16:24:04 +0000 (00:24 +0800)
committerJohn Crispin <john@phrozen.org>
Sat, 5 May 2018 06:47:51 +0000 (08:47 +0200)
These modules usually require some special arguments to customize the
emulated device and they should be loaded manually by users.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
package/kernel/linux/modules/usb.mk

index be638520aab81321dfcfa1fd9ef35f7cf1ad35b7..f6925fe0714b0da37f40ce37fc45fc032168c4f0 100644 (file)
@@ -131,7 +131,6 @@ define KernelPackage/usb-gadget-ehci-debug
        CONFIG_USB_G_DBGP_PRINTK=n
   DEPENDS:=+kmod-usb-gadget +kmod-usb-lib-composite +kmod-usb-gadget-serial
   FILES:=$(LINUX_DIR)/drivers/usb/gadget/legacy/g_dbgp.ko
-  AUTOLOAD:=$(call AutoLoad,52,g_dbgp)
   $(call AddDepends/usb)
 endef
 
@@ -154,7 +153,7 @@ define KernelPackage/usb-gadget-eth
        $(LINUX_DIR)/drivers/usb/gadget/function/usb_f_ecm_subset.ko \
        $(LINUX_DIR)/drivers/usb/gadget/function/usb_f_rndis.ko \
        $(LINUX_DIR)/drivers/usb/gadget/legacy/g_ether.ko
-  AUTOLOAD:=$(call AutoLoad,52,usb_f_ecm g_ether)
+  AUTOLOAD:=$(call AutoLoad,52,usb_f_ecm)
   $(call AddDepends/usb)
 endef
 
@@ -175,7 +174,7 @@ define KernelPackage/usb-gadget-serial
        $(LINUX_DIR)/drivers/usb/gadget/function/usb_f_obex.ko \
        $(LINUX_DIR)/drivers/usb/gadget/function/usb_f_serial.ko \
        $(LINUX_DIR)/drivers/usb/gadget/legacy/g_serial.ko
-  AUTOLOAD:=$(call AutoLoad,52,usb_f_acm g_serial)
+  AUTOLOAD:=$(call AutoLoad,52,usb_f_acm)
   $(call AddDepends/usb)
 endef
 
@@ -192,7 +191,7 @@ define KernelPackage/usb-gadget-mass-storage
   FILES:= \
        $(LINUX_DIR)/drivers/usb/gadget/function/usb_f_mass_storage.ko \
        $(LINUX_DIR)/drivers/usb/gadget/legacy/g_mass_storage.ko
-  AUTOLOAD:=$(call AutoLoad,52,usb_f_mass_storage g_mass_storage)
+  AUTOLOAD:=$(call AutoLoad,52,usb_f_mass_storage)
   $(call AddDepends/usb)
 endef