ath79: add TP-Link TL-WR703N port
authorAlex Maclean <monkeh@monkeh.net>
Wed, 30 May 2018 13:18:54 +0000 (14:18 +0100)
committerJohn Crispin <john@phrozen.org>
Fri, 1 Jun 2018 06:23:28 +0000 (08:23 +0200)
Signed-off-by: Alex Maclean <monkeh@monkeh.net>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/ar9331_tl-wr703n.dts [new file with mode: 0644]
target/linux/ath79/image/tiny-tp-link.mk

index 7dc90fcab768055a1fb72b4f5bcffdfa2ffba57d..a9eeb5b4559b4bc28870a17eec210d1378ebf341 100755 (executable)
@@ -9,6 +9,7 @@ ath79_setup_interfaces()
 
        case "$board" in
        "avm,fritz300e"|\
+       "tplink,tl-wr703n"|\
        "ubnt,unifi")
                ucidef_set_interface_lan "eth0"
                ;;
diff --git a/target/linux/ath79/dts/ar9331_tl-wr703n.dts b/target/linux/ath79/dts/ar9331_tl-wr703n.dts
new file mode 100644 (file)
index 0000000..70f94ed
--- /dev/null
@@ -0,0 +1,139 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9331.dtsi"
+
+/ {
+       compatible = "tplink,tl-wr703n", "qca,ar9331";
+       model = "TP-Link TL-WR703N";
+
+       aliases {
+               serial0 = &uart;
+               led-status = &led_system;
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x2000000>;
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+       
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               led_system: system {
+                       label = "tl-wr703n:blue:system";
+                       gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       reg_usb_vbus: reg_usb_vbus {
+               compatible = "regulator-fixed";
+               regulator-name = "usb_vbus";
+               regulator-min-microvolt = <5000000>;
+               regulator-max-microvolt = <5000000>;
+               gpio = <&gpio 8 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+       };
+
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               reg = <0x0 0x20000>;
+                               label = "u-boot";
+                               read-only;
+                       };
+
+                       firmware: partition@20000 {
+                               reg = <0x20000 0x3d0000>;
+                               label = "firmware";
+                       };
+
+                       art: partition@3f0000 {
+                               reg = <0x3f0000 0x10000>;
+                               label = "art";
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&phy4>;
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+
+       gmac-config {
+               device = <&gmac>;
+
+               switch-phy-addr-swap = <0>;
+               switch-phy-swap = <0>;
+       };
+};
+
+&gpio {
+       status = "okay";
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy4: ethernet-phy@4 {
+               reg = <4>;
+               phy-mode = "mii";
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&usb {
+       dr_mode = "host";
+       vbus-supply = <&reg_usb_vbus>;
+       status = "okay";
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&uboot 0x1fc00>;
+};
index 09180bd678a98075b1db0982201a8dcec16c2986..e6d5feefc5b188fbcd7a4ceee99aad2627d2c53c 100644 (file)
@@ -1,6 +1,16 @@
 include ./common-tp-link.mk
 
 
+define Device/tl-wr703n
+  $(Device/tplink-4mlzma)
+  ATH_SOC := ar9331
+  DEVICE_TITLE := TP-Link TL-WR703N
+  DEVICE_PACKAGES := kmod-usb-chipidea2
+  TPLINK_HWID := 0x07030101
+  SUPPORTED_DEVICES := tplink,tl-wr703n tl-wr703n
+endef
+TARGET_DEVICES += tl-wr703n
+
 define Device/tl-wr740n-v2
   $(Device/tplink-4m)
   ATH_SOC := ar7240