ar71xx: image: use the new helpers for the Zcomax images
authorGabor Juhos <juhosg@openwrt.org>
Thu, 23 Aug 2012 13:01:55 +0000 (13:01 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 23 Aug 2012 13:01:55 +0000 (13:01 +0000)
SVN-Revision: 33259

target/linux/ar71xx/image/Makefile

index a1d96a913b044fbe802bc3bf71bdd58fafab7b57..49a608e1e989a6a4cb04e2954ca2516a1aed0be6 100644 (file)
@@ -881,15 +881,9 @@ $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPAG300H,wzr-hp-ag300h,WZR-
 $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))
 
 zcn1523h_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6208k(rootfs),1472k(kernel),64k(configure)ro,64k(mfg)ro,64k(art)ro,7680k@0x50000(firmware)
-zcn1523h28_cmdline=board=ZCN-1523H-2 console=ttyS0,115200 $(zcn1523h_mtdlayout)
-define Image/Build/Profile/ZCN1523H28
-       $(call Image/Build/Template/$(fs_64k)/$(1),Zcomax,zcn-1523h-2-8,$(zcn1523h28_cmdline))
-endef
+$(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H28,zcn-1523h-2-8,ZCN-1523H-2,ttyS0,115200,$$(zcn1523h_mtdlayout)))
+$(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H516,zcn-1523h-5-16,ZCN-1523H-5,ttyS0,115200,$$(zcn1523h_mtdlayout)))
 
-zcn1523h516_cmdline=board=ZCN-1523H-5 console=ttyS0,115200 $(zcn1523h_mtdlayout)
-define Image/Build/Profile/ZCN1523H516
-       $(call Image/Build/Template/$(fs_64k)/$(1),Zcomax,zcn-1523h-5-16,$(zcn1523h516_cmdline))
-endef
 
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/ALFAAP96,$(1))