lldpd: fix passing multiple ifnames to the daemon
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Mar 2015 12:25:02 +0000 (12:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Mar 2015 12:25:02 +0000 (12:25 +0000)
Instead of multiple -I arguments, lldpd expects a comma separated list.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44585

package/network/services/lldpd/Makefile
package/network/services/lldpd/files/lldpd.init

index 88982d1a860e8c0a63d2921c88c429945435ccc3..5a1921e9d0b6b5432b42da705ca396f1182abbf3 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lldpd
 PKG_VERSION:=0.7.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
index b2eea70fd3577ccce092a7df24b929bf281a726c..2b1b22366370ced1029db36826464929f4fe7c5c 100644 (file)
@@ -37,14 +37,15 @@ start() {
        local ifaces
        config_get ifaces 'config' 'interface'
 
-       local iface
+       local iface ifnames=""
        for iface in $ifaces; do
                local ifname=""
                if network_get_device ifname "$iface" || [ -e "/sys/class/net/$iface" ]; then
-                       append args "-I ${ifname:-$iface}"
+                       append ifnames "${ifname:-$iface}" ","
                fi
        done
 
+       [ -n "$ifnames" ] && append args "-I $ifnames"
        [ $enable_cdp -gt 0 ] && append args '-c'
        [ $enable_fdp -gt 0 ] && append args '-f'
        [ $enable_sonmp -gt 0 ] && append args '-s'