bcm63xx: limit name metadata to model name
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Mon, 22 Feb 2021 17:07:02 +0000 (18:07 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Mon, 22 Feb 2021 17:29:44 +0000 (18:29 +0100)
Since there are only 16 characters available, on most cases the vendor name
will fit in the metadata, but the model name won't fit.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm63xx/image/Makefile

index 822e26e9935a224a569c5ecd4fffa024997a8c41..f35358173c5f1494c2ae1a874a0868312b14b778 100644 (file)
@@ -84,10 +84,6 @@ endef
 define rootfspad/squashfs
 endef
 
-define Image/LimitName16
-$(shell expr substr "$(1)" 1 16)
-endef
-
 define Image/FileSystemStrip
 $(firstword $(subst +,$(space),$(subst root.,,$(notdir $(1)))))
 endef
@@ -96,7 +92,7 @@ define Build/cfe-bin
        $(STAGING_DIR_HOST)/bin/imagetag -i $(IMAGE_KERNEL) -f $(IMAGE_ROOTFS) \
                --output $@ --boardid $(CFE_BOARD_ID) --chipid $(CHIP_ID) \
                --entry $(LOADER_ENTRY) --load-addr $(LOADER_ENTRY) \
-               --info1 "$(call Image/LimitName16,$(DEVICE_NAME))" \
+               --info1 "$(call ModelNameLimit16,$(DEVICE_NAME))" \
                --info2 "$(call Image/FileSystemStrip,$(IMAGE_ROOTFS))" \
                $(call rootfspad/$(call Image/FileSystemStrip,$(IMAGE_ROOTFS))) \
                $(CFE_EXTRAS) $(1)